aboutsummaryrefslogtreecommitdiffstats
path: root/package/libnl
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-11-16 03:10:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-11-16 03:10:56 +0000
commit77a96c54371bb0f47d2e0d187b53b1b7dc63e885 (patch)
treef75dc7eaabf7bd7baacc8cc8440484d88d3666e2 /package/libnl
parent6fe9aab05af416e345d4a741f278dcb394490302 (diff)
downloadupstream-77a96c54371bb0f47d2e0d187b53b1b7dc63e885.tar.gz
upstream-77a96c54371bb0f47d2e0d187b53b1b7dc63e885.tar.bz2
upstream-77a96c54371bb0f47d2e0d187b53b1b7dc63e885.zip
fix up hostapd for mac80211
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9554 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libnl')
-rw-r--r--package/libnl/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/package/libnl/Makefile b/package/libnl/Makefile
index 9f334108ed..28958f4a51 100644
--- a/package/libnl/Makefile
+++ b/package/libnl/Makefile
@@ -36,16 +36,19 @@ define Build/Compile
install
endef
-define Build/InstallDev
+ifneq ($(CONFIG_LINUX_2_6_23),)
+ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/* $(1)/
-endef
+ $(CP) $(PKG_BUILD_DIR)/include/linux $(1)/usr/include/
+ endef
-define Build/UninstallDev
-endef
+ define Build/UninstallDev
+ endef
-define Package/libnl/install
+ define Package/libnl/install
$(INSTALL_DIR) $(1)/usr/lib
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libnl.so.1 $(1)/usr/lib/
-endef
+ endef
+endif
$(eval $(call BuildPackage,libnl))