aboutsummaryrefslogtreecommitdiffstats
path: root/package/libnl
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-11-16 03:10:33 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-11-16 03:10:33 +0000
commit5e5f9f681022ec3984322bacf599f06b6a41f65c (patch)
tree93d7b326e438c6f8f1ae91d8705379b1af6e1da2 /package/libnl
parent4992bf6ce541c15729e1fe9a1e57bc75c5d77c3f (diff)
downloadupstream-5e5f9f681022ec3984322bacf599f06b6a41f65c.tar.gz
upstream-5e5f9f681022ec3984322bacf599f06b6a41f65c.tar.bz2
upstream-5e5f9f681022ec3984322bacf599f06b6a41f65c.zip
add libnl
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9552 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libnl')
-rw-r--r--package/libnl/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/package/libnl/Makefile b/package/libnl/Makefile
new file mode 100644
index 0000000000..9f334108ed
--- /dev/null
+++ b/package/libnl/Makefile
@@ -0,0 +1,51 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libnl
+PKG_VERSION:=1.0-pre7
+PKG_RELEASE:=1
+
+PKG_SOURCE:=libnl-1.0-pre7.tar.gz
+PKG_SOURCE_URL:=http://www.suug.ch/~tgr/libnl/files/
+PKG_MD5SUM:=db9f6265c370f09defd2d2fa3540758e
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libnl
+ SECTION:=net
+ CATEGORY:=Base system
+ TITLE:=netlink socket library
+ URL:=http://www.suug.ch/~tgr/libnl/
+endef
+
+define Package/libnl/description
+ This package contains a library for applications dealing with netlink sockets
+endef
+
+define Build/Compile
+ $(call Build/Compile/Default)
+ make -C $(PKG_BUILD_DIR) \
+ DESTDIR="$(PKG_INSTALL_DIR)" \
+ install
+endef
+
+define Build/InstallDev
+ $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+endef
+
+define Build/UninstallDev
+endef
+
+define Package/libnl/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libnl.so.1 $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libnl))