aboutsummaryrefslogtreecommitdiffstats
path: root/package/libnl-tiny
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-04-01 05:32:32 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-04-01 05:32:32 +0000
commit981370cdb4483cc95e4a0363039562dc0faacf79 (patch)
tree4d7b5e7aaa0ab62adfa558831ea9e8198c25a755 /package/libnl-tiny
parent384eee1817b1bbe1b04ae4c922846061a88d5a69 (diff)
downloadupstream-981370cdb4483cc95e4a0363039562dc0faacf79.tar.gz
upstream-981370cdb4483cc95e4a0363039562dc0faacf79.tar.bz2
upstream-981370cdb4483cc95e4a0363039562dc0faacf79.zip
[package] libnl-tiny: port upstream bugfix 8ee16e6688657886f591f0841cb8e892743ecf2a from libnl, fixes error on hostapd interface initialization
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31155 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libnl-tiny')
-rw-r--r--package/libnl-tiny/Makefile4
-rw-r--r--package/libnl-tiny/src/socket.c2
2 files changed, 3 insertions, 3 deletions
diff --git a/package/libnl-tiny/Makefile b/package/libnl-tiny/Makefile
index f964249283..37ac26fe9c 100644
--- a/package/libnl-tiny/Makefile
+++ b/package/libnl-tiny/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libnl-tiny
PKG_VERSION:=0.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
include $(INCLUDE_DIR)/package.mk
diff --git a/package/libnl-tiny/src/socket.c b/package/libnl-tiny/src/socket.c
index 6fe56fdc53..1429825e63 100644
--- a/package/libnl-tiny/src/socket.c
+++ b/package/libnl-tiny/src/socket.c
@@ -59,7 +59,7 @@ static void release_local_port(uint32_t port)
return;
nr = port >> 22;
- used_ports_map[nr / 32] &= ~((nr % 32) + 1);
+ used_ports_map[nr / 32] &= ~(1 << nr % 32);
}
/**