aboutsummaryrefslogtreecommitdiffstats
path: root/package/libnl-tiny/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-10-08 11:24:12 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-10-08 11:24:12 +0000
commit48db59fab785ce881e154d83115de86d284fce5d (patch)
tree8741bab5dbcca43c884cdf0788b6c0049e0c25d1 /package/libnl-tiny/Makefile
parent997ace7e5e78d580d802f3f30ddc00f9b30e0bcc (diff)
downloadupstream-48db59fab785ce881e154d83115de86d284fce5d.tar.gz
upstream-48db59fab785ce881e154d83115de86d284fce5d.tar.bz2
upstream-48db59fab785ce881e154d83115de86d284fce5d.zip
move library packages to package/libs/
SVN-Revision: 33657
Diffstat (limited to 'package/libnl-tiny/Makefile')
-rw-r--r--package/libnl-tiny/Makefile52
1 files changed, 0 insertions, 52 deletions
diff --git a/package/libnl-tiny/Makefile b/package/libnl-tiny/Makefile
deleted file mode 100644
index 37ac26fe9c..0000000000
--- a/package/libnl-tiny/Makefile
+++ /dev/null
@@ -1,52 +0,0 @@
-#
-# Copyright (C) 2006-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libnl-tiny
-PKG_VERSION:=0.1
-PKG_RELEASE:=3
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/libnl-tiny
- SECTION:=libs
- CATEGORY:=Libraries
- TITLE:=netlink socket library
-endef
-
-define Package/libnl-tiny/description
- This package contains a stripped down version of libnl
-endef
-
-define Build/Prepare
- mkdir -p $(PKG_BUILD_DIR)
- $(CP) ./src/* $(PKG_BUILD_DIR)/
-endef
-
-TARGET_CFLAGS += $(FPIC)
-
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- all
-endef
-
-define Build/InstallDev
- $(INSTALL_DIR) $(1)/usr/lib/pkgconfig $(1)/usr/include/libnl-tiny
- $(CP) $(PKG_BUILD_DIR)/include/* $(1)/usr/include/libnl-tiny
- $(CP) $(PKG_BUILD_DIR)/libnl-tiny.so $(1)/usr/lib/
- $(CP) ./files/libnl-tiny.pc $(1)/usr/lib/pkgconfig
-endef
-
-define Package/libnl-tiny/install
- $(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_BUILD_DIR)/libnl-tiny.so $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,libnl-tiny))