aboutsummaryrefslogtreecommitdiffstats
path: root/package/libipfix/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-03-26 20:56:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-03-26 20:56:36 +0000
commit47abb6b3c307fe0d4845a61a2c91101218f745a1 (patch)
tree6676c94dffb9b8dd8c87d98a3fee7f25392d3958 /package/libipfix/Makefile
parent964f6031c558df44e068edf831324cde3a294955 (diff)
downloadupstream-47abb6b3c307fe0d4845a61a2c91101218f745a1.tar.gz
upstream-47abb6b3c307fe0d4845a61a2c91101218f745a1.tar.bz2
upstream-47abb6b3c307fe0d4845a61a2c91101218f745a1.zip
add libipfix
SVN-Revision: 15049
Diffstat (limited to 'package/libipfix/Makefile')
-rw-r--r--package/libipfix/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/package/libipfix/Makefile b/package/libipfix/Makefile
new file mode 100644
index 0000000000..44d5050c18
--- /dev/null
+++ b/package/libipfix/Makefile
@@ -0,0 +1,48 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libipfix
+PKG_VERSION:=r51
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
+PKG_MD5SUM:=0e5b2871ea20ac48eda3f6006c5dba28
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME).$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libipfix
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=IP Flow Information Export Library
+ URL:=http://www.fokus.fraunhofer.de/de/net/more_about/download/ipfixlib.html
+ BUILDONLY:=1
+endef
+
+TARGET_CFLAGS += \
+ -ffunction-sections -fdata-sections
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ CCOPT="$(TARGET_CFLAGS) -I$(BUILD_DIR)/linux/include" \
+ prefix="$(PKG_INSTALL_DIR)/usr" \
+ exec_prefix="$(PKG_INSTALL_DIR)/usr" \
+ all install
+ $(TARGET_CROSS)ranlib $(PKG_INSTALL_DIR)/usr/lib/libipfix.a
+ $(TARGET_CROSS)ranlib $(PKG_INSTALL_DIR)/usr/lib/libmisc.a
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)
+ $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+endef
+
+$(eval $(call BuildPackage,libipfix))