aboutsummaryrefslogtreecommitdiffstats
path: root/package/kexec-tools
diff options
context:
space:
mode:
authorGeoff Levand <geoffrey.levand@am.sony.com>2009-08-24 20:11:46 +0000
committerGeoff Levand <geoffrey.levand@am.sony.com>2009-08-24 20:11:46 +0000
commita64a3b373a191e8056a572f50695bf9ba2414714 (patch)
treec48ae26441cf683876a24e06ad0b7b723b4d1087 /package/kexec-tools
parent66663e3314270420245cef860235cc1c6df2beb1 (diff)
downloadupstream-a64a3b373a191e8056a572f50695bf9ba2414714.tar.gz
upstream-a64a3b373a191e8056a572f50695bf9ba2414714.tar.bz2
upstream-a64a3b373a191e8056a572f50695bf9ba2414714.zip
kexec-tools: Make build of kdump optional
Most systems won't need kdump, so make its build optional. Signed-off-by: Geoff Levand <geoffrey.levand@am.sony.com> SVN-Revision: 17374
Diffstat (limited to 'package/kexec-tools')
-rw-r--r--package/kexec-tools/Makefile16
-rw-r--r--package/kexec-tools/kexec-config.in9
2 files changed, 20 insertions, 5 deletions
diff --git a/package/kexec-tools/Makefile b/package/kexec-tools/Makefile
index 4374b5b937..7ee1c2cd5b 100644
--- a/package/kexec-tools/Makefile
+++ b/package/kexec-tools/Makefile
@@ -56,15 +56,21 @@ CONFIGURE_VARS += \
BUILD_CC="$(HOSTCC)" \
TARGET_CC="$(TARGET_CC)"
+kexec-extra-sbin-$(CONFIG_KEXEC_TOOLS_kdump) += kdump
+
define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) all
+ $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
endef
define Package/kexec-tools/install
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(1)" \
- install
- rm -rf $(1)/usr/man
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) \
+ $(addprefix $(PKG_INSTALL_DIR)/usr/sbin/, \
+ $(kexec-extra-sbin-y)) \
+ $(kexec-extra-bin-y) \
+ $(PKG_INSTALL_DIR)/usr/sbin/kexec \
+ $(1)/usr/sbin
+
endef
$(eval $(call BuildPackage,kexec-tools))
diff --git a/package/kexec-tools/kexec-config.in b/package/kexec-tools/kexec-config.in
index 7aa3f1db2e..25fed1b7cd 100644
--- a/package/kexec-tools/kexec-config.in
+++ b/package/kexec-tools/kexec-config.in
@@ -8,3 +8,12 @@ config KEXEC_TOOLS_TARGET_NAME
Defines the target type of the kernels that kexec deals
with. This should be the target specification of
the kernel you're booting.
+
+config KEXEC_TOOLS_kdump
+ bool
+ prompt "kdump support"
+ depends on PACKAGE_kexec-tools
+ default n
+ help
+ Include the kdump utility.
+