aboutsummaryrefslogtreecommitdiffstats
path: root/package/kexec-tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-28 13:28:18 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-28 13:28:18 +0000
commit96c42dce806b42e947a743453e09dbff20c804d7 (patch)
treecd914aa7a96f6a3892f09698bb21b58e2365e362 /package/kexec-tools
parent07b49e249a54285aecdfbc3e5757c499cb20be14 (diff)
downloadupstream-96c42dce806b42e947a743453e09dbff20c804d7.tar.gz
upstream-96c42dce806b42e947a743453e09dbff20c804d7.tar.bz2
upstream-96c42dce806b42e947a743453e09dbff20c804d7.zip
fix kexec-tools build
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6428 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kexec-tools')
-rw-r--r--package/kexec-tools/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/package/kexec-tools/Makefile b/package/kexec-tools/Makefile
index 23294fd39b..d88fc0583c 100644
--- a/package/kexec-tools/Makefile
+++ b/package/kexec-tools/Makefile
@@ -33,12 +33,17 @@ define Package/kexec-tools
URL:=http://www.xmission.com/~ebiederm/files/kexec/README
endef
+MAKE_FLAGS += \
+ DESTDIR="$(PKG_INSTALL_DIR)" \
+ EXTRA_CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
+ BUILD_CFLAGS="-O2" \
+ LIBS="$(TARGET_LDFLAGS) -lz" \
+ install
+
define Build/Compile
rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- install
+ $(call Build/Compile/Default,)
endef
define Package/kexec-tools/install