aboutsummaryrefslogtreecommitdiffstats
path: root/package/kexec-tools
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-16 11:03:50 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-16 11:03:50 +0000
commit4ebd9856ff5e0534ffb2a29ff80805b72d12ab07 (patch)
treecd736443b4f5910c9531605b5f62fe952b31bac3 /package/kexec-tools
parentdb0251cf14a4fba8808588b2e4a033c75b1484b4 (diff)
downloadupstream-4ebd9856ff5e0534ffb2a29ff80805b72d12ab07.tar.gz
upstream-4ebd9856ff5e0534ffb2a29ff80805b72d12ab07.tar.bz2
upstream-4ebd9856ff5e0534ffb2a29ff80805b72d12ab07.zip
package/kexec-tools: move configuration in submenu, rename 'kexec-config.in' in 'Config.in' for coherency
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20916 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kexec-tools')
-rw-r--r--package/kexec-tools/Config.in (renamed from package/kexec-tools/kexec-config.in)6
-rw-r--r--package/kexec-tools/Makefile2
2 files changed, 5 insertions, 3 deletions
diff --git a/package/kexec-tools/kexec-config.in b/package/kexec-tools/Config.in
index 25fed1b7cd..60c819d798 100644
--- a/package/kexec-tools/kexec-config.in
+++ b/package/kexec-tools/Config.in
@@ -1,7 +1,9 @@
+menu "Configuration"
+ depends on PACKAGE_kexec-tools
config KEXEC_TOOLS_TARGET_NAME
string
- prompt "Target name for kexec kernel" if PACKAGE_kexec-tools
+ prompt "Target name for kexec kernel"
default EXTRA_TARGET_ARCH_NAME if powerpc64
default ARCH
help
@@ -12,8 +14,8 @@ config KEXEC_TOOLS_TARGET_NAME
config KEXEC_TOOLS_kdump
bool
prompt "kdump support"
- depends on PACKAGE_kexec-tools
default n
help
Include the kdump utility.
+endmenu
diff --git a/package/kexec-tools/Makefile b/package/kexec-tools/Makefile
index d350bb2c8b..978bb6fd50 100644
--- a/package/kexec-tools/Makefile
+++ b/package/kexec-tools/Makefile
@@ -34,7 +34,7 @@ define Package/kexec-tools/description
endef
define Package/kexec-tools/config
- source "$(SOURCE)/kexec-config.in"
+ source "$(SOURCE)/Config.in"
endef
KEXEC_TARGET_NAME:=$(call qstrip,$(CONFIG_KEXEC_TOOLS_TARGET_NAME))-linux-$(TARGET_SUFFIX)