aboutsummaryrefslogtreecommitdiffstats
path: root/package/kexec-tools
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-01-08 01:49:11 +0000
committerNicolas Thill <nico@openwrt.org>2009-01-08 01:49:11 +0000
commit3b75e47f8f0d1db7575f0824f7a2469e2e8af7cf (patch)
treee9676ee4d01368996c17caf45fd31f861e3686af /package/kexec-tools
parentec57cd80ccfc739b1d9856e7f2191d12ef568aeb (diff)
downloadupstream-3b75e47f8f0d1db7575f0824f7a2469e2e8af7cf.tar.gz
upstream-3b75e47f8f0d1db7575f0824f7a2469e2e8af7cf.tar.bz2
upstream-3b75e47f8f0d1db7575f0824f7a2469e2e8af7cf.zip
[massive] add support for alternative C libraries (currently only glibc/eglibc)
other (related) changes: - kernel headers are now installed using "make headers_install" on 2.6 - target names now contain an openwrt "vendor" tag (e.g. mips-openwrt-linux-gnu) - build directory names now contain gcc/libc name/version - default cpu for x86 is now i486 (required to build glibc/eglibc) git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13931 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kexec-tools')
-rw-r--r--package/kexec-tools/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/package/kexec-tools/Makefile b/package/kexec-tools/Makefile
index cef46db4fe..e497542468 100644
--- a/package/kexec-tools/Makefile
+++ b/package/kexec-tools/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -37,7 +37,7 @@ define Package/kexec-tools/config
endef
CONFIGURE_ARGS = \
- --target=$(CONFIG_KEXEC_TOOLS_TARGET_NAME)-linux-uclibc \
+ --target=$(CONFIG_KEXEC_TOOLS_TARGET_NAME)-linux-$(TARGET_SUFFIX) \
--host=$(GNU_TARGET_NAME)-uclibc \
--build=$(GNU_HOST_NAME) \
--program-prefix="" \
@@ -49,7 +49,9 @@ CONFIGURE_ARGS = \
--libexecdir=/usr/lib \
--sysconfdir=/etc \
-CONFIGURE_VARS += BUILD_CC=$(HOSTCC)
+CONFIGURE_VARS += \
+ BUILD_CC=$(HOSTCC) \
+ TARGET_CC=$(TARGET_CC) \
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) all