aboutsummaryrefslogtreecommitdiffstats
path: root/package/kexec-tools
diff options
context:
space:
mode:
authorGeoff Levand <geoff@infradead.org>2009-08-24 20:11:46 +0000
committerGeoff Levand <geoff@infradead.org>2009-08-24 20:11:46 +0000
commit2aa44e86687404f89d3ba72e25bed4336fd17eea (patch)
treedc7926e3a6c466d54c6124599665460d39ce563d /package/kexec-tools
parentfb26523f67a679f6430baa2ab26fb661508c99e3 (diff)
downloadupstream-2aa44e86687404f89d3ba72e25bed4336fd17eea.tar.gz
upstream-2aa44e86687404f89d3ba72e25bed4336fd17eea.tar.bz2
upstream-2aa44e86687404f89d3ba72e25bed4336fd17eea.zip
kexec-tools: Make build of kdump optional
Most systems won't need kdump, so make its build optional. Signed-off-by: Geoff Levand <geoffrey.levand@am.sony.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17374 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kexec-tools')
-rw-r--r--package/kexec-tools/Makefile16
-rw-r--r--package/kexec-tools/kexec-config.in9
2 files changed, 20 insertions, 5 deletions
diff --git a/package/kexec-tools/Makefile b/package/kexec-tools/Makefile
index 4374b5b937..7ee1c2cd5b 100644
--- a/package/kexec-tools/Makefile
+++ b/package/kexec-tools/Makefile
@@ -56,15 +56,21 @@ CONFIGURE_VARS += \
BUILD_CC="$(HOSTCC)" \
TARGET_CC="$(TARGET_CC)"
+kexec-extra-sbin-$(CONFIG_KEXEC_TOOLS_kdump) += kdump
+
define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) all
+ $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
endef
define Package/kexec-tools/install
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(1)" \
- install
- rm -rf $(1)/usr/man
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) \
+ $(addprefix $(PKG_INSTALL_DIR)/usr/sbin/, \
+ $(kexec-extra-sbin-y)) \
+ $(kexec-extra-bin-y) \
+ $(PKG_INSTALL_DIR)/usr/sbin/kexec \
+ $(1)/usr/sbin
+
endef
$(eval $(call BuildPackage,kexec-tools))
diff --git a/package/kexec-tools/kexec-config.in b/package/kexec-tools/kexec-config.in
index 7aa3f1db2e..25fed1b7cd 100644
--- a/package/kexec-tools/kexec-config.in
+++ b/package/kexec-tools/kexec-config.in
@@ -8,3 +8,12 @@ config KEXEC_TOOLS_TARGET_NAME
Defines the target type of the kernels that kexec deals
with. This should be the target specification of
the kernel you're booting.
+
+config KEXEC_TOOLS_kdump
+ bool
+ prompt "kdump support"
+ depends on PACKAGE_kexec-tools
+ default n
+ help
+ Include the kdump utility.
+