aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorChris Blake <chrisrblake93@gmail.com>2022-02-14 18:55:32 -0600
committerChristian Lamparter <chunkeey@gmail.com>2022-06-19 12:31:02 +0200
commit77a14795dfd5488d62ec5f5cf04b7bd7a8c278ee (patch)
tree5b5073ec8b0459a14176b31bec31f234f8e178b9 /package/kernel
parent78ecaebdff78378b0c9b081ac9beae29a69dbf69 (diff)
downloadupstream-77a14795dfd5488d62ec5f5cf04b7bd7a8c278ee.tar.gz
upstream-77a14795dfd5488d62ec5f5cf04b7bd7a8c278ee.tar.bz2
upstream-77a14795dfd5488d62ec5f5cf04b7bd7a8c278ee.zip
kernel: add kmod-leds-pca955x
This patch adds support for the mainline kernel module for the PCA955x LED driver. Note this requires i2c and GPIO support. Also worth calling out this driver also enables GPIO support, depending on device tree configuration. Signed-off-by: Chris Blake <chrisrblake93@gmail.com>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/leds.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/leds.mk b/package/kernel/linux/modules/leds.mk
index 33b9f612ae..7b5609a84c 100644
--- a/package/kernel/linux/modules/leds.mk
+++ b/package/kernel/linux/modules/leds.mk
@@ -131,6 +131,25 @@ endef
$(eval $(call KernelPackage,leds-apu))
+define KernelPackage/leds-pca955x
+ SUBMENU:=$(LEDS_MENU)
+ TITLE:=LED driver for PCA955x I2C chips
+ DEPENDS:=@GPIO_SUPPORT +kmod-i2c-core
+ KCONFIG:=CONFIG_LEDS_PCA955X \
+ CONFIG_LEDS_PCA955X_GPIO=y
+ FILES:=$(LINUX_DIR)/drivers/leds/leds-pca955x.ko
+ AUTOLOAD:=$(call AutoLoad,60,leds-pca955x,1)
+endef
+
+define KernelPackage/leds-pca955x/description
+ This option enables support for LEDs connected to PCA955x
+ LED driver chips accessed via the I2C bus. Supported
+ devices include PCA9550, PCA9551, PCA9552, and PCA9553.
+endef
+
+$(eval $(call KernelPackage,leds-pca955x))
+
+
define KernelPackage/leds-pca963x
SUBMENU:=$(LEDS_MENU)
TITLE:=PCA963x LED support