aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2023-05-17 09:38:48 -0600
committerChristian Lamparter <chunkeey@gmail.com>2023-05-21 14:25:52 +0200
commit3b2337b467b7bb39746a244e82506ffbbfae4897 (patch)
treefda326e9c6ab401cafb6920c56fb46656dc335dc /package/kernel
parent066441b5e4919ab6a59a41f00209b8c8d19dc8a5 (diff)
downloadupstream-3b2337b467b7bb39746a244e82506ffbbfae4897.tar.gz
upstream-3b2337b467b7bb39746a244e82506ffbbfae4897.tar.bz2
upstream-3b2337b467b7bb39746a244e82506ffbbfae4897.zip
kernel: disable IGD (video DRM) support
IGD is only useful when accelerating a VM guest that wants to direct render to memory in the host's framebuffer, but since OpenWrt typically runs on headless hardware, this serves no purpose. Also build vfio with VFIO_NOIOMMU undefined (to get all of the code enabled), but allow it to be enabled via boot-time modparams settings (or at run-time via sysfs writes to "/sys/module/vfio/parameters/enable_unsafe_noiommu_mode". Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/virt.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/virt.mk b/package/kernel/linux/modules/virt.mk
index 85f47aacbf..90226b4806 100644
--- a/package/kernel/linux/modules/virt.mk
+++ b/package/kernel/linux/modules/virt.mk
@@ -82,6 +82,8 @@ define KernelPackage/vfio
CONFIG_VFIO \
CONFIG_VFIO_NOIOMMU=n \
CONFIG_VFIO_MDEV=n
+ MODPARAMS.vfio:=\
+ enable_unsafe_noiommu_mode=n
FILES:= \
$(LINUX_DIR)/drivers/vfio/vfio.ko \
$(LINUX_DIR)/drivers/vfio/vfio_virqfd.ko \
@@ -102,7 +104,7 @@ define KernelPackage/vfio-pci
DEPENDS:=@TARGET_x86_64 @PCI_SUPPORT +kmod-vfio +kmod-irqbypass
KCONFIG:= \
CONFIG_VFIO_PCI \
- CONFIG_VFIO_PCI_IGD=y
+ CONFIG_VFIO_PCI_IGD=n
FILES:= \
$(LINUX_DIR)/drivers/vfio/pci/vfio-pci-core.ko \
$(LINUX_DIR)/drivers/vfio/pci/vfio-pci.ko