aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2023-05-04 21:38:25 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-12 13:02:43 +0200
commit330ad3e98fc2f33c40dbf6dd3dd08527afbd9f1f (patch)
treebe893b71ee0f38c3989c9079a79511f8535d554d /package/kernel
parent5bd7f04806d07a82e247220f2b825f4fcc43da9f (diff)
downloadupstream-330ad3e98fc2f33c40dbf6dd3dd08527afbd9f1f.tar.gz
upstream-330ad3e98fc2f33c40dbf6dd3dd08527afbd9f1f.tar.bz2
upstream-330ad3e98fc2f33c40dbf6dd3dd08527afbd9f1f.zip
kernel: remove unnecessary qca-sdk patch for 5.10 kernel
We removed 5.10 kernel, so remove also the patch that only affects 5.10 kernels. Manually refresh: - 0005-SSDK-config-add-kernel-5.15.patch - 0010-QSDK-config-Avoid-Werror-heroics.patch Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/qca-ssdk/patches/0001-SSDK-config-add-kernel-5.10.patch56
-rw-r--r--package/kernel/qca-ssdk/patches/0005-SSDK-config-add-kernel-5.15.patch18
-rw-r--r--package/kernel/qca-ssdk/patches/0010-QSDK-config-Avoid-Werror-heroics.patch4
3 files changed, 11 insertions, 67 deletions
diff --git a/package/kernel/qca-ssdk/patches/0001-SSDK-config-add-kernel-5.10.patch b/package/kernel/qca-ssdk/patches/0001-SSDK-config-add-kernel-5.10.patch
deleted file mode 100644
index be83d6f1ee..0000000000
--- a/package/kernel/qca-ssdk/patches/0001-SSDK-config-add-kernel-5.10.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From 6ee395e1cab32d1d4899d7846ea99e6e2dc0a9e4 Mon Sep 17 00:00:00 2001
-From: Robert Marko <robimarko@gmail.com>
-Date: Wed, 12 May 2021 13:41:12 +0200
-Subject: [PATCH 01/11] SSDK: config: add kernel 5.10
-
-This is purely to identify it and be able to set
-flags correctly.
-
-Signed-off-by: Robert Marko <robimarko@gmail.com>
----
- config | 6 +++++-
- make/linux_opt.mk | 4 ++--
- 2 files changed, 7 insertions(+), 3 deletions(-)
-
---- a/config
-+++ b/config
-@@ -24,6 +24,10 @@ ifeq ($(KVER),$(filter 5.4%,$(KVER)))
- OS_VER=5_4
- endif
-
-+ifeq ($(KVER),$(filter 5.10%,$(KVER)))
-+OS_VER=5_10
-+endif
-+
- ifeq ($(KVER), 3.4.0)
- OS_VER=3_4
- endif
-@@ -132,7 +136,7 @@ ifeq ($(ARCH), arm)
- endif
-
- ifeq ($(ARCH), arm64)
-- ifeq ($(KVER),$(filter 4.1% 4.4% 4.9% 5.4%,$(KVER)))
-+ ifeq ($(KVER),$(filter 4.1% 4.4% 4.9% 5.4% 5.10%,$(KVER)))
- CPU_CFLAG= -DMODULE -Os -pipe -march=armv8-a -mcpu=cortex-a53+crypto -fno-caller-saves -fno-strict-aliasing -Werror -fno-common -Wno-format-security -Wno-pointer-sign -Wno-unused-but-set-variable -Wno-error=unused-result -mcmodel=large
- endif
- endif
---- a/make/linux_opt.mk
-+++ b/make/linux_opt.mk
-@@ -437,7 +437,7 @@ ifeq (KSLIB, $(MODULE_TYPE))
- KASAN_SHADOW_SCALE_SHIFT := 3
- endif
-
-- ifeq (5_4, $(OS_VER))
-+ ifeq ($(OS_VER),$(filter 5_4 5_10, $(OS_VER)))
- ifeq ($(ARCH), arm64)
- KASAN_OPTION += -DKASAN_SHADOW_SCALE_SHIFT=$(KASAN_SHADOW_SCALE_SHIFT)
- endif
-@@ -468,7 +468,7 @@ ifeq (KSLIB, $(MODULE_TYPE))
-
- endif
-
-- ifeq ($(OS_VER),$(filter 4_4 5_4, $(OS_VER)))
-+ ifeq ($(OS_VER),$(filter 4_4 5_4 5_10, $(OS_VER)))
- MODULE_CFLAG += -DKVER34
- MODULE_CFLAG += -DKVER32
- MODULE_CFLAG += -DLNX26_22
diff --git a/package/kernel/qca-ssdk/patches/0005-SSDK-config-add-kernel-5.15.patch b/package/kernel/qca-ssdk/patches/0005-SSDK-config-add-kernel-5.15.patch
index 045f7ae40b..7b19f5d12c 100644
--- a/package/kernel/qca-ssdk/patches/0005-SSDK-config-add-kernel-5.15.patch
+++ b/package/kernel/qca-ssdk/patches/0005-SSDK-config-add-kernel-5.15.patch
@@ -14,8 +14,8 @@ Signed-off-by: Robert Marko <robimarko@gmail.com>
--- a/config
+++ b/config
-@@ -28,6 +28,10 @@ ifeq ($(KVER),$(filter 5.10%,$(KVER)))
- OS_VER=5_10
+@@ -24,6 +24,10 @@ ifeq ($(KVER),$(filter 5.4%,$(KVER)))
+ OS_VER=5_4
endif
+ifeq ($(KVER),$(filter 5.15%,$(KVER)))
@@ -25,12 +25,12 @@ Signed-off-by: Robert Marko <robimarko@gmail.com>
ifeq ($(KVER), 3.4.0)
OS_VER=3_4
endif
-@@ -136,7 +140,7 @@ ifeq ($(ARCH), arm)
+@@ -132,7 +136,7 @@ ifeq ($(ARCH), arm)
endif
ifeq ($(ARCH), arm64)
-- ifeq ($(KVER),$(filter 4.1% 4.4% 4.9% 5.4% 5.10%,$(KVER)))
-+ ifeq ($(KVER),$(filter 4.1% 4.4% 4.9% 5.4% 5.10% 5.15%,$(KVER)))
+- ifeq ($(KVER),$(filter 4.1% 4.4% 4.9% 5.4%,$(KVER)))
++ ifeq ($(KVER),$(filter 4.1% 4.4% 4.9% 5.4% 5.15%,$(KVER)))
CPU_CFLAG= -DMODULE -Os -pipe -march=armv8-a -mcpu=cortex-a53+crypto -fno-caller-saves -fno-strict-aliasing -Werror -fno-common -Wno-format-security -Wno-pointer-sign -Wno-unused-but-set-variable -Wno-error=unused-result -mcmodel=large
endif
endif
@@ -40,8 +40,8 @@ Signed-off-by: Robert Marko <robimarko@gmail.com>
KASAN_SHADOW_SCALE_SHIFT := 3
endif
-- ifeq ($(OS_VER),$(filter 5_4 5_10, $(OS_VER)))
-+ ifeq ($(OS_VER),$(filter 5_4 5_10 5_15, $(OS_VER)))
+- ifeq (5_4, $(OS_VER))
++ ifeq (5_4 5_15, $(OS_VER))
ifeq ($(ARCH), arm64)
KASAN_OPTION += -DKASAN_SHADOW_SCALE_SHIFT=$(KASAN_SHADOW_SCALE_SHIFT)
endif
@@ -49,8 +49,8 @@ Signed-off-by: Robert Marko <robimarko@gmail.com>
endif
-- ifeq ($(OS_VER),$(filter 4_4 5_4 5_10, $(OS_VER)))
-+ ifeq ($(OS_VER),$(filter 4_4 5_4 5_10 5_15, $(OS_VER)))
+- ifeq ($(OS_VER),$(filter 4_4 5_4, $(OS_VER)))
++ ifeq ($(OS_VER),$(filter 4_4 5_4 5_15, $(OS_VER)))
MODULE_CFLAG += -DKVER34
MODULE_CFLAG += -DKVER32
MODULE_CFLAG += -DLNX26_22
diff --git a/package/kernel/qca-ssdk/patches/0010-QSDK-config-Avoid-Werror-heroics.patch b/package/kernel/qca-ssdk/patches/0010-QSDK-config-Avoid-Werror-heroics.patch
index f5884f279b..8eff0a9958 100644
--- a/package/kernel/qca-ssdk/patches/0010-QSDK-config-Avoid-Werror-heroics.patch
+++ b/package/kernel/qca-ssdk/patches/0010-QSDK-config-Avoid-Werror-heroics.patch
@@ -19,10 +19,10 @@ Signed-off-by: Alexandru Gagniuc <mr.nuke.me@gmail.com>
--- a/config
+++ b/config
-@@ -141,7 +141,7 @@ endif
+@@ -137,7 +137,7 @@ endif
ifeq ($(ARCH), arm64)
- ifeq ($(KVER),$(filter 4.1% 4.4% 4.9% 5.4% 5.10% 5.15%,$(KVER)))
+ ifeq ($(KVER),$(filter 4.1% 4.4% 4.9% 5.4% 5.15%,$(KVER)))
- CPU_CFLAG= -DMODULE -Os -pipe -march=armv8-a -mcpu=cortex-a53+crypto -fno-caller-saves -fno-strict-aliasing -Werror -fno-common -Wno-format-security -Wno-pointer-sign -Wno-unused-but-set-variable -Wno-error=unused-result -mcmodel=large
+ CPU_CFLAG= -DMODULE -Os -pipe -march=armv8-a -mcpu=cortex-a53+crypto -fno-caller-saves -fno-strict-aliasing -fno-common -Wno-format-security -Wno-pointer-sign -Wno-unused-but-set-variable -Wno-error=unused-result -mcmodel=large
endif