aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2021-09-08 14:14:27 +0200
committerChristian Lamparter <chunkeey@gmail.com>2021-11-01 00:56:51 +0100
commitb69dfb0a99cf228d99ff4bc9a0848df85969ce7d (patch)
tree547fe4682c7ca6059dd8ba6121ccccc04c3a76b8 /package/kernel
parent8550086c24e54b8d333045315e59947b9badf08e (diff)
downloadupstream-b69dfb0a99cf228d99ff4bc9a0848df85969ce7d.tar.gz
upstream-b69dfb0a99cf228d99ff4bc9a0848df85969ce7d.tar.bz2
upstream-b69dfb0a99cf228d99ff4bc9a0848df85969ce7d.zip
kernel/modules: prevent bonding driver to create default bond0 interface
When loading the bonding driver, bonding interface are automatically created on bonding module load. > ip a s bond0 > 14: bond0: <BROADCAST,MULTICAST,MASTER> mtu 1500 qdisc noop state DOWN > group default qlen 1000 > link/ether a6:f2:20:64:c1:b9 brd ff:ff:ff:ff:ff:ff This is not necessary in openwrt as we do not use this created interface. The netifd creates a bonding interface based on its network configuration name and configures this over the netifd bonding proto handler. In order to keep the overview of the interfaces clear, bonding interfaces should not be created automatically when loading this module, because they are not used anyway. Signed-off-by: Florian Eckert <fe@dev.tdt.de>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/netsupport.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 62d79db51e..166172dbf3 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -48,6 +48,7 @@ define KernelPackage/bonding
KCONFIG:=CONFIG_BONDING
FILES:=$(LINUX_DIR)/drivers/net/bonding/bonding.ko
AUTOLOAD:=$(call AutoLoad,40,bonding)
+ MODPARAMS.bonding:=max_bonds=0
endef
define KernelPackage/bonding/description