aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorHauke Mehrtens <hmehrtens@maxlinear.com>2022-08-04 18:44:51 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-11-05 22:55:50 +0100
commit23ccc71c615b8ebe0d9a9c8d697b2ad0823dfcf7 (patch)
tree3a608e746c14bc2d5f1014e5e65779488d8c0d42 /package/kernel
parent3ca45248fd9bf5b52dc2bd03a4c18ce1795bf1dd (diff)
downloadupstream-23ccc71c615b8ebe0d9a9c8d697b2ad0823dfcf7.tar.gz
upstream-23ccc71c615b8ebe0d9a9c8d697b2ad0823dfcf7.tar.bz2
upstream-23ccc71c615b8ebe0d9a9c8d697b2ad0823dfcf7.zip
kernel: netsupport: Extract act_police
This extracts kmod-sched-act-police to allow using it without adding all the packages from the big kmod-sched package. Signed-off-by: Hauke Mehrtens <hmehrtens@maxlinear.com> (cherry picked from commit 0582acf42967e47c16eb3193f91ca65b01b57e8e)
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/netsupport.mk15
1 files changed, 13 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 399cf5bd92..86b384f6e1 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -775,6 +775,18 @@ endef
$(eval $(call KernelPackage,sched-core))
+define KernelPackage/sched-act-police
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=Traffic Policing
+ DEPENDS:=+kmod-sched-core
+ KCONFIG:=CONFIG_NET_ACT_POLICE
+ FILES:=$(LINUX_DIR)/net/sched/act_police.ko
+ AUTOLOAD:=$(call AutoProbe,act_police)
+endef
+
+$(eval $(call KernelPackage,sched-act-police))
+
+
define KernelPackage/sched-act-sample
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=Traffic Sampling
@@ -968,7 +980,7 @@ endef
$(eval $(call KernelPackage,bpf-test))
-SCHED_MODULES_EXTRA = sch_codel sch_dsmark sch_gred sch_multiq sch_sfq sch_teql sch_fq sch_pie act_police act_ipt act_pedit act_simple act_csum em_cmp em_nbyte em_meta em_text
+SCHED_MODULES_EXTRA = sch_codel sch_dsmark sch_gred sch_multiq sch_sfq sch_teql sch_fq sch_pie act_ipt act_pedit act_simple act_csum em_cmp em_nbyte em_meta em_text
SCHED_FILES_EXTRA = $(foreach mod,$(SCHED_MODULES_EXTRA),$(LINUX_DIR)/net/sched/$(mod).ko)
define KernelPackage/sched
@@ -984,7 +996,6 @@ define KernelPackage/sched
CONFIG_NET_SCH_TEQL \
CONFIG_NET_SCH_FQ \
CONFIG_NET_SCH_PIE \
- CONFIG_NET_ACT_POLICE \
CONFIG_NET_ACT_IPT \
CONFIG_NET_ACT_PEDIT \
CONFIG_NET_ACT_SIMP \