aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2022-02-01 13:37:24 +0100
committerChristian Lamparter <chunkeey@gmail.com>2022-02-20 14:26:40 +0100
commit808210d992fe4107e8c7f8525e9e6dbf753fad75 (patch)
tree7af19f28c8f97b310d0183f1efe53caec3c51fe1 /package/kernel
parentc1e06a0cbb0ffede0bf619c0e2c6e5bf1f5020b8 (diff)
downloadupstream-808210d992fe4107e8c7f8525e9e6dbf753fad75.tar.gz
upstream-808210d992fe4107e8c7f8525e9e6dbf753fad75.tar.bz2
upstream-808210d992fe4107e8c7f8525e9e6dbf753fad75.zip
mac80211: add debug compile option for rtw88 devices
This commit adds the following package compile options. CONFIG_PACKAGE_RTW88_DEBGUG: Compile the driver with additional debug logging output CONFIG_PACKAGE_RTW88_DEBGUGFS: Add the possibility to map information about the driver rtw88 into debugfs. Signed-off-by: Florian Eckert <fe@dev.tdt.de>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/mac80211/realtek.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/kernel/mac80211/realtek.mk b/package/kernel/mac80211/realtek.mk
index 75cb94d7b6..44c6c25b08 100644
--- a/package/kernel/mac80211/realtek.mk
+++ b/package/kernel/mac80211/realtek.mk
@@ -27,6 +27,8 @@ config-y += STAGING
config-$(call config_package,rtw88) += RTW88 RTW88_CORE RTW88_PCI
config-y += RTW88_8822BE RTW88_8822CE RTW88_8723DE
+config-$(CONFIG_PACKAGE_RTW88_DEBUG) += RTW88_DEBUG
+config-$(CONFIG_PACKAGE_RTW88_DEBUGFS) += RTW88_DEBUGFS
define KernelPackage/rtl818x/Default
$(call KernelPackage/mac80211/Default)
@@ -175,6 +177,22 @@ define KernelPackage/rtl8xxxu/description
Please report your results!
endef
+define KernelPackage/rtw88/config
+ config PACKAGE_RTW88_DEBUG
+ bool "Realtek wireless debugging (rtw88)"
+ depends on PACKAGE_kmod-rtw88
+ help
+ Enable debugging output for rtw88 devices
+
+ config PACKAGE_RTW88_DEBUGFS
+ bool "Enable rtw88 debugfS support"
+ select KERNEL_DEBUG_FS
+ depends on PACKAGE_kmod-rtw88
+ help
+ Select this to see extensive information about
+ the internal state of rtw88 in debugfs.
+endef
+
define KernelPackage/rtw88
$(call KernelPackage/mac80211/Default)
TITLE:=Realtek RTL8822BE/RTL8822CE/RTL8723DE