aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2021-12-28 23:43:57 +0100
committerChristian Lamparter <chunkeey@gmail.com>2022-01-08 23:23:22 +0100
commit31647d8be8c60bfb6690c87c739b8abe6dc03950 (patch)
tree88fd9a5907d2da729a4c19a2cc9a4c28e25ce730 /package/kernel
parent3fabca88944e736176310be06e97f0f3cc9010cb (diff)
downloadupstream-31647d8be8c60bfb6690c87c739b8abe6dc03950.tar.gz
upstream-31647d8be8c60bfb6690c87c739b8abe6dc03950.tar.bz2
upstream-31647d8be8c60bfb6690c87c739b8abe6dc03950.zip
kernel: add kmod-usb-net-lan78xx
Add kernel module for Microchip LAN78XX based USB 2 & USB 3 10/100/1000 Ethernet adapters. [1] This kernel module is required for the Seeed Studio's Mini Router based on RPI CM4 [2]. [1] <https://cateee.net/lkddb/web-lkddb/USB_LAN78XX.html> [2] <https://www.seeedstudio.com/Dual-GbE-Carrier-Board-with-4GB-RAM-32GB-eMMC-RPi-CM4-Case-p-5029.html> Link: <https://github.com/openwrt/openwrt/pull/4893> Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com> (added kmod-phy-microchip and kmod-fixed-phy dependencies, rpi3 needs lan78xx but has it built-in) Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/usb.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 8815b153ef..6f73c96a29 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1201,6 +1201,23 @@ endef
$(eval $(call KernelPackage,usb-net-kaweth))
+define KernelPackage/usb-net-lan78xx
+ TITLE:=USB-To-Ethernet Microchip LAN78XX convertors
+ DEPENDS:=+kmod-fixed-phy +kmod-phy-microchip
+ KCONFIG:=CONFIG_USB_LAN78XX
+ FILES:=$(LINUX_DIR)/drivers/$(USBNET_DIR)/lan78xx.ko
+ AUTOLOAD:=$(call AutoProbe,lan78xx)
+ $(call AddDepends/usb-net)
+endef
+
+define KernelPackage/usb-net-lan78xx/description
+ Kernel module for Microchip LAN78XX based USB 2 & USB 3
+ 10/100/1000 Ethernet adapters.
+endef
+
+$(eval $(call KernelPackage,usb-net-lan78xx))
+
+
define KernelPackage/usb-net-pegasus
TITLE:=Kernel module for USB-to-Ethernet Pegasus convertors
KCONFIG:=CONFIG_USB_PEGASUS