aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2021-12-16 21:52:37 +0100
committerChristian Lamparter <chunkeey@gmail.com>2022-01-15 17:41:19 +0100
commit1ed50b92d1572831f940d1a0248b29fab577e49c (patch)
treed64157af4f0d9b4877ef3cf82c696c6d408d4234 /package/kernel
parent01520a96e7c71363e4dfc3e123aee48bcf811c1c (diff)
downloadupstream-1ed50b92d1572831f940d1a0248b29fab577e49c.tar.gz
upstream-1ed50b92d1572831f940d1a0248b29fab577e49c.tar.bz2
upstream-1ed50b92d1572831f940d1a0248b29fab577e49c.zip
package: kernel: add driver module for NCT7802Y
This commit add package with hwmon-nct7802 module. This driver implements support for the Nuvoton NCT7802Y hardware monitoring chip. NCT7802Y supports 6 temperature sensors, 5 voltage sensors, and 3 fan speed sensors. Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com> (fixed c&p'ed module description) Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/hwmon.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 226ecec31d..01a510e571 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -348,6 +348,21 @@ endef
$(eval $(call KernelPackage,hwmon-nct6775))
+define KernelPackage/hwmon-nct7802
+ TITLE:=NCT7802Y and compatibles monitoring support
+ KCONFIG:=CONFIG_SENSORS_NCT7802
+ FILES:=$(LINUX_DIR)/drivers/hwmon/nct7802.ko
+ AUTOLOAD:=$(call AutoProbe,nct7802)
+ $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-nct7802/description
+ Kernel module for NCT7802Y thermal monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-nct7802))
+
+
define KernelPackage/hwmon-pc87360
TITLE:=PC87360 monitoring support
KCONFIG:=CONFIG_SENSORS_PC87360