aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorAndrew Robbins <andrew@robbinsa.me>2021-10-05 11:00:16 -0400
committerHauke Mehrtens <hauke@hauke-m.de>2021-10-21 00:19:43 +0200
commit284f8a64b735e703aa00baa2a5fc4e5629bbf988 (patch)
treed2ab5f19a48e9a433074adb19377e6ba1d6773aa /package/kernel
parentaa2d61eced0f63105fe663f65d4fc542c6da4aed (diff)
downloadupstream-284f8a64b735e703aa00baa2a5fc4e5629bbf988.tar.gz
upstream-284f8a64b735e703aa00baa2a5fc4e5629bbf988.tar.bz2
upstream-284f8a64b735e703aa00baa2a5fc4e5629bbf988.zip
ath10k-ct: update to version from 2021-09-22
Add in a fix for 160Mhz dfs on 5.10 and higher. Add support for 5.13 and 5.15 kernels. Add of_get_mac_address support for 5.15 driver. Signed-off-by: Andrew Robbins <andrew@robbinsa.me> (cherry picked from commit 1d2bc94f786434e89bc87003b2a2202e92ad84e7)
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/ath10k-ct/Makefile6
-rw-r--r--package/kernel/ath10k-ct/patches/202-ath10k-use-tpt-trigger-by-default.patch2
2 files changed, 4 insertions, 4 deletions
diff --git a/package/kernel/ath10k-ct/Makefile b/package/kernel/ath10k-ct/Makefile
index 5681c5c2cd..25ea3376f0 100644
--- a/package/kernel/ath10k-ct/Makefile
+++ b/package/kernel/ath10k-ct/Makefile
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
PKG_SOURCE_URL:=https://github.com/greearb/ath10k-ct.git
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2021-06-03
-PKG_SOURCE_VERSION:=b44cd7b2e7b0df5995ece18f358d4dfc40834ba1
-PKG_MIRROR_HASH:=59f961ad425eb1a48fa9c391a325cc0f23845daec9d12673445d3077f9756cf0
+PKG_SOURCE_DATE:=2021-09-22
+PKG_SOURCE_VERSION:=e6a7d5b5b834737cd12e357b5efdc2e42d923bf6
+PKG_MIRROR_HASH:=62a1b97089d3561730656ef73beb3cd77231ec636645115cc1bbb3c6c84a6fe3
# Build the 5.10 ath10k-ct driver version.
# Probably this should match as closely as
diff --git a/package/kernel/ath10k-ct/patches/202-ath10k-use-tpt-trigger-by-default.patch b/package/kernel/ath10k-ct/patches/202-ath10k-use-tpt-trigger-by-default.patch
index 6205c9b661..168c6ab462 100644
--- a/package/kernel/ath10k-ct/patches/202-ath10k-use-tpt-trigger-by-default.patch
+++ b/package/kernel/ath10k-ct/patches/202-ath10k-use-tpt-trigger-by-default.patch
@@ -42,7 +42,7 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
if (ret)
--- a/ath10k-5.10/mac.c
+++ b/ath10k-5.10/mac.c
-@@ -11403,7 +11403,7 @@ int ath10k_mac_register(struct ath10k *a
+@@ -11405,7 +11405,7 @@ int ath10k_mac_register(struct ath10k *a
ar->hw->weight_multiplier = ATH10K_AIRTIME_WEIGHT_MULTIPLIER;
#ifdef CPTCFG_MAC80211_LEDS