aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2019-08-04 16:29:39 +0800
committerJo-Philipp Wich <jo@mein.io>2019-09-04 13:36:43 +0200
commite2db2df644e7be85a21794355cb60f17aabe4e4f (patch)
tree99e6612be55f874b3aa3d0c83ffdc31de2b2c2d6 /package/kernel
parentf7b53dfb2abf0ac99f4ed97fcbbcfcbcb1d98192 (diff)
downloadupstream-e2db2df644e7be85a21794355cb60f17aabe4e4f.tar.gz
upstream-e2db2df644e7be85a21794355cb60f17aabe4e4f.tar.bz2
upstream-e2db2df644e7be85a21794355cb60f17aabe4e4f.zip
gpio-button-hotplug: add volume button handling
This is used by PISEN WMB001N. Signed-off-by: Chuanhong Guo <gch981213@gmail.com> (cherry picked from commit 11182349e1f31f873ebddd69d6b87dec638eaabf)
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/gpio-button-hotplug/Makefile2
-rw-r--r--package/kernel/gpio-button-hotplug/src/gpio-button-hotplug.c2
2 files changed, 3 insertions, 1 deletions
diff --git a/package/kernel/gpio-button-hotplug/Makefile b/package/kernel/gpio-button-hotplug/Makefile
index 216d23b76d..ffbc19756c 100644
--- a/package/kernel/gpio-button-hotplug/Makefile
+++ b/package/kernel/gpio-button-hotplug/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=gpio-button-hotplug
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_LICENSE:=GPL-2.0
include $(INCLUDE_DIR)/package.mk
diff --git a/package/kernel/gpio-button-hotplug/src/gpio-button-hotplug.c b/package/kernel/gpio-button-hotplug/src/gpio-button-hotplug.c
index edd03d2b62..3e8e0ea268 100644
--- a/package/kernel/gpio-button-hotplug/src/gpio-button-hotplug.c
+++ b/package/kernel/gpio-button-hotplug/src/gpio-button-hotplug.c
@@ -95,6 +95,8 @@ static struct bh_map button_map[] = {
BH_MAP(KEY_RESTART, "reset"),
BH_MAP(KEY_RFKILL, "rfkill"),
BH_MAP(KEY_VIDEO, "video"),
+ BH_MAP(KEY_VOLUMEDOWN, "volume_down"),
+ BH_MAP(KEY_VOLUMEUP, "volume_up"),
BH_MAP(KEY_WIMAX, "wwan"),
BH_MAP(KEY_WLAN, "wlan"),
BH_MAP(KEY_WPS_BUTTON, "wps"),