aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2018-05-13 18:21:59 +0200
committerJo-Philipp Wich <jo@mein.io>2018-05-13 18:24:38 +0200
commit56bd23cf529fa4dd840bfe6e615bcac470791f36 (patch)
treefe0453252749240137b8e1ac2cd458b03866214d /package/kernel
parent404508001e9f2bbf09fc4c4027cf16b8720124db (diff)
downloadupstream-56bd23cf529fa4dd840bfe6e615bcac470791f36.tar.gz
upstream-56bd23cf529fa4dd840bfe6e615bcac470791f36.tar.bz2
upstream-56bd23cf529fa4dd840bfe6e615bcac470791f36.zip
kernel: let kmod-rtl8366-smi conditionally depend on kmod-of-mdio
We cannot depend on CONFIG_OF in the module definition context as this symbol is not defined for OpenWrt menuconfig. Depend on the targets that appear to need the kmod-of-mdio module instead. The target dependency list may not be complete, it is based on the build failures encountered by the build bots. Fixes: dc629d9cf5 ("kernel: fix kmod-switch-rtl8366-smi dependency") Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/netdevices.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index f5e6d3d6f0..0da8bcdf56 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -209,7 +209,7 @@ $(eval $(call KernelPackage,switch-ip17xx))
define KernelPackage/switch-rtl8366-smi
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Realtek RTL8366 SMI switch interface support
- DEPENDS:=@GPIO_SUPPORT +kmod-swconfig +CONFIG_OF:kmod-of-mdio
+ DEPENDS:=@GPIO_SUPPORT +kmod-swconfig +(TARGET_armvirt||TARGET_brcm2708_bcm2708):kmod-of-mdio
KCONFIG:=CONFIG_RTL8366_SMI
FILES:=$(LINUX_DIR)/drivers/net/phy/rtl8366_smi.ko
AUTOLOAD:=$(call AutoLoad,42,rtl8366_smi)