aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-04-19 15:42:16 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-04-19 15:42:16 +0000
commitc5824507b554dc78fd2445e8725ba42dbf25fe2a (patch)
tree24b9486b61423eec79b71884e98a2d78de3794f6 /package/kernel
parent437de7d88cd6f9eea3ce0d9d9c7c52cb4e98fee6 (diff)
downloadupstream-c5824507b554dc78fd2445e8725ba42dbf25fe2a.tar.gz
upstream-c5824507b554dc78fd2445e8725ba42dbf25fe2a.tar.bz2
upstream-c5824507b554dc78fd2445e8725ba42dbf25fe2a.zip
[PATCH] [kernel] add sata_sil24 module
Signed-off-by: Erik Inge Bols? <knan-openwrt@anduin.net> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15261 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/block.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/modules/block.mk b/package/kernel/modules/block.mk
index 3c27813972..ce9596e8a8 100644
--- a/package/kernel/modules/block.mk
+++ b/package/kernel/modules/block.mk
@@ -35,6 +35,22 @@ endef
$(eval $(call KernelPackage,ata-ahci))
+define KernelPackage/ata-sil24
+ SUBMENU:=3D$(BLOCK_MENU)
+ TITLE:=3DSilicon Image 3124/3132 SATA support
+ DEPENDS:=3Dkmod-ata-core
+ KCONFIG:=3DCONFIG_SATA_SIL24
+ FILES:=3D$(LINUX_DIR)/drivers/ata/sata_sil24.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=3D$(call AutoLoad,41,sata_sil24)
+endef
+
+define KernelPackage/ata-sil24/description
+ Support for Silicon Image 3124/3132 Serial ATA controllers.
+endef
+
+$(eval $(call KernelPackage,ata-sil24))
+
+
define KernelPackage/ata-artop
SUBMENU:=$(BLOCK_MENU)
TITLE:=ARTOP 6210/6260 PATA support