aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2017-11-12 22:06:38 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2017-12-16 22:13:04 +0100
commit199273324ee705edc35b49a02fc1a28e635610ab (patch)
tree9bffea794f472384a2ac32e7f79822e1f6f4e6b2 /package/kernel
parentf1e839dd33243973c8bd044e03066967a4b7405d (diff)
downloadupstream-199273324ee705edc35b49a02fc1a28e635610ab.tar.gz
upstream-199273324ee705edc35b49a02fc1a28e635610ab.tar.bz2
upstream-199273324ee705edc35b49a02fc1a28e635610ab.zip
kernel: add kmod-crypto-ecdh
In kernel 4.14 kmod-bluetooth depends on kmod-crypto-ecdh, add kmod-crypto-ecdh to LEDE. Both packages also depend on the kmod-crypto-kpp package. To build this we have to fix the dependency of CRYPTO_ECDH which has a typo. This patch is already accepted upstream. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/crypto.mk25
-rw-r--r--package/kernel/linux/modules/other.mk2
2 files changed, 26 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index a0c47634b6..b05552006a 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -137,6 +137,19 @@ endef
$(eval $(call KernelPackage,crypto-rsa))
+define KernelPackage/crypto-ecdh
+ TITLE:=ECDH algorithm
+ DEPENDS:=@!(LINUX_3_18||LINUX_4_4) +kmod-crypto-kpp
+ KCONFIG:= CONFIG_CRYPTO_ECDH
+ FILES:= \
+ $(LINUX_DIR)/crypto/ecdh_generic.ko
+ AUTOLOAD:=$(call AutoLoad,10,ecdh_generic)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-ecdh))
+
+
define KernelPackage/crypto-iv
TITLE:=CryptoAPI initialization vectors
DEPENDS:=+kmod-crypto-manager +kmod-crypto-rng +kmod-crypto-wq
@@ -348,6 +361,18 @@ endef
$(eval $(call KernelPackage,crypto-des))
+define KernelPackage/crypto-kpp
+ TITLE:=Key-agreement Protocol Primitives
+ KCONFIG:=CONFIG_CRYPTO_KPP
+ HIDDEN:=1
+ FILES:=$(LINUX_DIR)/crypto/kpp.ko
+ AUTOLOAD:=$(call AutoLoad,09,kpp)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-kpp))
+
+
define KernelPackage/crypto-acompress
TITLE:=Asynchronous Compression operations
HIDDEN:=1
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 8e2f3a012d..b3ad4a051e 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -30,7 +30,7 @@ $(eval $(call KernelPackage,6lowpan))
define KernelPackage/bluetooth
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth support
- DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +kmod-crypto-ecb +kmod-lib-crc16 +kmod-hid +!LINUX_3_18:kmod-crypto-cmac +!LINUX_3_18:kmod-regmap
+ DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +kmod-crypto-ecb +kmod-lib-crc16 +kmod-hid +!LINUX_3_18:kmod-crypto-cmac +!LINUX_3_18:kmod-regmap +LINUX_4_14:kmod-crypto-ecdh
KCONFIG:= \
CONFIG_BLUEZ \
CONFIG_BLUEZ_L2CAP \