aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-07-10 19:42:48 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-07-10 19:42:48 +0000
commit0e479250a6ed6fd6653df8da6d17a44046afd43c (patch)
treeedc9747c0688db44914d4eee1097492af9c7b4ad /package/kernel
parent9e40952c92994aeb3f1ca8d24fba4612ab02c4ce (diff)
downloadupstream-0e479250a6ed6fd6653df8da6d17a44046afd43c.tar.gz
upstream-0e479250a6ed6fd6653df8da6d17a44046afd43c.tar.bz2
upstream-0e479250a6ed6fd6653df8da6d17a44046afd43c.zip
kernel: package the HW random core module
And update the crypto-hw-hifn-795x to use it. Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 37231
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/crypto.mk2
-rw-r--r--package/kernel/linux/modules/other.mk14
2 files changed, 15 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index be76f53251..065ddbfecb 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -164,8 +164,8 @@ $(eval $(call KernelPackage,crypto-hw-geode))
define KernelPackage/crypto-hw-hifn-795x
TITLE:=HIFN 795x crypto accelerator
+ DEPENDS:=+kmod-random-core
KCONFIG:= \
- CONFIG_HW_RANDOM=y \
CONFIG_CRYPTO_DEV_HIFN_795X \
CONFIG_CRYPTO_DEV_HIFN_795X_RNG=y
FILES:=$(LINUX_DIR)/drivers/crypto/hifn_795x.ko
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 387090aec3..94bf5dd6cf 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -684,3 +684,17 @@ define KernelPacakge/ptp-gianfar/description
endef
$(eval $(call KernelPackage,ptp-gianfar))
+
+define KernelPackage/random-core
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Hardware Random Number Generator Core support
+ KCONFIG:=CONFIG_HW_RANDOM
+ FILES:=$(LINUX_DIR)/drivers/char/hw_random/rng-core.ko
+ AUTOLOAD:=$(call AutoLoad,10,rng-core)
+endef
+
+define KernelPackage/random-core/description
+ Kernel module for the HW random number generator core infrastructure
+endef
+
+$(eval $(call KernelPackage,random-core))