aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-07-16 06:15:07 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-07-16 06:15:07 +0000
commita158af99a0bcf40ccfc79a79b712a34108061488 (patch)
treecde2d8fea738ce14784396f767339bb05c7c85b7 /package/kernel
parente62a9791ee4be2e2ade71d566faf4d5b2b1627f5 (diff)
downloadupstream-a158af99a0bcf40ccfc79a79b712a34108061488.tar.gz
upstream-a158af99a0bcf40ccfc79a79b712a34108061488.tar.bz2
upstream-a158af99a0bcf40ccfc79a79b712a34108061488.zip
iptables: package hashlimit module (#6696)
SVN-Revision: 22229
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/netfilter.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/kernel/modules/netfilter.mk b/package/kernel/modules/netfilter.mk
index 561286efda..510c195d62 100644
--- a/package/kernel/modules/netfilter.mk
+++ b/package/kernel/modules/netfilter.mk
@@ -512,3 +512,17 @@ define KernelPackage/nf-conntrack-netlink/description
endef
$(eval $(call KernelPackage,nf-conntrack-netlink))
+
+define KernelPackage/ipt-hashlimit
+$(call KernelPackage/ipt/Depends,)
+ TITLE:=Netfilter hashlimit match
+ FILES:=$(LINUX_DIR)/net/netfilter/xt_hashlimit.$(LINUX_KMOD_SUFFIX)
+ KCONFIG:=$(KCONFIG_IPT_HASHLIMIT)
+ AUTOLOAD:=$(call AutoLoad,50,xt_hashlimit)
+endef
+
+define KernelPackage/ipt-hashlimit/description
+ Kernel modules support for the hashlimit bucket match module
+endef
+
+$(eval $(call KernelPackage,ipt-hashlimit))