aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-09-04 18:06:24 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-09-04 18:06:24 +0000
commit5bd1c17fd1e269dfacb6a9283432189c59af2457 (patch)
tree5c635a06cf1c267b919464e1c07e30c158b18c64 /package/kernel
parent0ca31140aa3536be7dfde4f8744d1b5ef8201227 (diff)
downloadupstream-5bd1c17fd1e269dfacb6a9283432189c59af2457.tar.gz
upstream-5bd1c17fd1e269dfacb6a9283432189c59af2457.tar.bz2
upstream-5bd1c17fd1e269dfacb6a9283432189c59af2457.zip
add XTS cipher CryptoAPI module
needed for proper dm-crypt support Signed-off-by: Jan Willies <jan@willies.info> SVN-Revision: 22915
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/crypto.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/modules/crypto.mk b/package/kernel/modules/crypto.mk
index fa2ddbc211..421e37fa71 100644
--- a/package/kernel/modules/crypto.mk
+++ b/package/kernel/modules/crypto.mk
@@ -356,3 +356,20 @@ endef
$(eval $(call KernelPackage,crypto-test))
+
+define KernelPackage/crypto-xts
+ TITLE:=XTS cipher CryptoAPI module
+ KCONFIG:= \
+ CONFIG_CRYPTO_GF128MUL \
+ CONFIG_CRYPTO_XTS
+ FILES:= \
+ $(LINUX_DIR)/crypto/xts.ko \
+ $(LINUX_DIR)/crypto/gf128mul.ko
+ AUTOLOAD:=$(call AutoLoad,09, \
+ gf128mul \
+ xts \
+ )
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-xts))