aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2019-03-07 20:36:51 +0100
committerFelix Fietkau <nbd@nbd.name>2019-03-07 20:36:52 +0100
commit8de93ce7455a61838871b43f1d69be3b67a2741e (patch)
treea18b1709faf62d53b44810980572e6da212221f3 /package/kernel
parent85cb473f9381cbca4b6bd537582e0f785284f2d9 (diff)
downloadupstream-8de93ce7455a61838871b43f1d69be3b67a2741e.tar.gz
upstream-8de93ce7455a61838871b43f1d69be3b67a2741e.tar.bz2
upstream-8de93ce7455a61838871b43f1d69be3b67a2741e.zip
mt76: update to the latest version
28d81ff mt76x0: eeprom: fix VHT mcs{8,9} rate power offset 6e33ce6 mt76: move mt76_mcu_msg_alloc in mt76-core 4637f95 mt76: move mt76_mcu_get_response in mt76-core 1763cb0 mt76: move mt76_mcu_rx_event in mt76-core 4db9d75 mt76x0: mcu: remove useless commented configuration 91d0455 mt76: move mt76_dma_tx_queue_skb_raw in mt76-core module 0e8e53f mt76: remove add_buf pointer in mt76_queue_ops db47920 mt7603: rely on mt76_mcu_msg_alloc routine 471c447 mt7603: rely on mt76_mcu_get_response routine cacc986 mt7603: rely on mt76_mcu_rx_event routine 11ab620 mt7603: rely on mt76_tx_queue_skb_raw common routine 82fa312 mt7603: move alloc_dev common code in mt76_alloc_device 47d5922 mt76: move alloc_device common code in mt76_alloc_device c50c993 mt76x2u: remove mt76x2u_alloc_device routine 6ed5b7a mt76x0: remove mt76x0u_alloc_device routine e32e249 mt76x2: remove mt76x2_alloc_device routine 6aacd1e mt76: change the return type of mt76_dma_attach() a10e9e5 mt76x02u: use usb_bulk_msg to upload firmware a774ff6 mt76: usb: fix possible NULL pointer dereference in mt76u_mcu_deinit c2877bc mt76: usb: fix possible memory leak in mt76u_buf_free a5cfe96 mt76: usb: do not run mt76u_queues_deinit twice 1e4db14 mt76: usb: move mt76u_check_sg in usb.c 302406b mt76: usb: do not use sg buffers for mcu messages 8ab5267 mt76: usb: use a linear buffer for tx/rx datapath if sg is not supported a0a3505 mt76: usb: introduce disable_usb_sg parameter 0cee180 mt76: usb: use dev_err_ratelimited instead of dev_err in mt76u_complete_rx 1bb97c4 mt76x02u: remove bogus check and comment padding 2cbc2d4 mt76: Use the correct hweight8() function f18e03a mt76x0u: fix suspend/resume 6231336 mt76: mt76x02: fix TSF sync mode 783da04 mt76: mt76x02: fix beacon timer drift adjustment 43d2507 mt76: mt76x02: fix beacon timer issue 59a6587 mt76: mt76x02: only reset beacon drift counter when enabling beacons 8c8eb98 mt76: mt76x02: issue watchdog reset on MCU request timeout 52161d2 mt76: mt76x02: fix ED/CCA enabling/disabling 5e7ecce mt76: mt76x2: unify mt76x2[u]_mac_resume 18af219 mt76: mt76x02: set MT_TXOP_HLDR_TX40M_BLK_EN for mt76x2 e5747b2 mt76usb: allow mt76u_bulk_msg be used for reads 2437a9a mt76usb: use synchronous msg for mcu command responses e4250c9 mt76usb: remove usb_mcu.c 8b1110e mt76: usb: fix warning in mt76u_buf_free 89215f6 mt76: usb: introduce mt76u_fill_bulk_urb routine 523e374 mt76: usb: simplify rx buffer allocation ffe1292 mt76: usb: simplify mt76u_tx_build_sg routine e2a9d40 mt7603: fix ba window size selection b040ef7 mt76: remove no longer used routine declarations 645ef43 mt76: usb: check urb->num_sgs limit in mt76u_process_rx_entry fd315bd mt7603: disable dynamic sensitivity adjustment by default 3c6df9b mt76: rewrite dma descriptor base and ring size on queue reset 30e757e mt76: mt76x02: when setting a key, use PN from mac80211 fa83406 mt76: mt76x2: implement full device restart on watchdog reset ead881b mt76: mt76x02: do not sync PN for keys with sw_iv set ba1d989 mt76: mmio: move mt76x02_set_irq_mask in mt76 module 283ebbe mt76: dma: move mt76x02_init_{tx,rx}_queue in mt76 module b216d3c mt76: introduce q->stopped parameter 8b437d2 mt76x02: clear sta and vif driver data structures on add 2c62d03 mt76x02: clear running flag when resetting state on restart 6b10cfc mt76: mt76x02: only update the base mac address if necessary 669bc49 mt76: mt76x02: reduce false positives in ED/CCA tx blocking 2ed9382 mt76: mt7603: fix tx status HT rate validation d2c6823 mt76: mt76x2: fix external LNA gain settings 8ee2259 mt76: mt76x2: fix 2.4 GHz channel gain settings 8bfe6d4 mt76: mt7603: clear ps filtering mode before releasing buffered frames d13b065 mt76: mt7603: fix up hardware queue index for PS filtered packets eb1ecc4 mt76: mt7603: notify mac80211 about buffered frames in ps queue 3687eec mt76: mt7603: clear the service period on releasing PS filtered packets 42ab27e mt76: when releasing PS frames, end the service period if no frame was found 461f3b0 mt76: mt76x02: disable ED/CCA by default 1d7760d mt76: mt7603: set moredata flag when queueing ps-filtered packets 0b927b2 mt76: fix return value check in mt76_wmac_probe() e72376d mt76x02: fix hdr pointer in write txwi for USB Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/mt76/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/kernel/mt76/Makefile b/package/kernel/mt76/Makefile
index 736717e251..1c82663e5f 100644
--- a/package/kernel/mt76/Makefile
+++ b/package/kernel/mt76/Makefile
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
PKG_SOURCE_URL:=https://github.com/openwrt/mt76
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2019-02-03
-PKG_SOURCE_VERSION:=74075efe4432b562182cb6284a833f7a780c4654
-PKG_MIRROR_HASH:=4661464b54c9baece068e50e6c62658452edb85b7625fcbaab21098f4714eb23
+PKG_SOURCE_DATE:=2019-03-04
+PKG_SOURCE_VERSION:=e72376d2f03a5b4b19b00bbefd80023de6d218f6
+PKG_MIRROR_HASH:=5cf64fbad25f78038aa2ca9c873e07762792c782e7401bfc088b2c37c3bdc92f
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_BUILD_PARALLEL:=1