aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorTony Ambardar <itugrok@yahoo.com>2018-10-30 05:50:51 -0700
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2019-02-11 20:18:48 +0000
commit59b58ad4c800be6f1846745ed07f0a022b5fccac (patch)
tree0be74bb9d275f4c07c74d7defe20343d24e28b89 /package/kernel
parentf54e9f183ec25186f66c70f4984d935f3f51247e (diff)
downloadupstream-59b58ad4c800be6f1846745ed07f0a022b5fccac.tar.gz
upstream-59b58ad4c800be6f1846745ed07f0a022b5fccac.tar.bz2
upstream-59b58ad4c800be6f1846745ed07f0a022b5fccac.zip
kernel/modules: kmod-sched: add some common, useful actions
Add act_pedit, act_csum, act_gact and act_simple modules for additional tc action support. Module act_simple helps with debug and logging, similar to iptables LOG target, while act_gact provides common generic actions. Modules act_pedit and act_csum support general packet mangling, and have been the subject of feature requests and forum discussions (e.g. DSCP), as well as being added to the Turris OS fork of OpenWrt ~2 years ago. Also select dependency kmod-lib-crc32c to support act_csum. Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/netsupport.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 8e6be05916..96fd778176 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -770,7 +770,7 @@ $(eval $(call KernelPackage,sched-connmark))
define KernelPackage/sched
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=Extra traffic schedulers
- DEPENDS:=+kmod-sched-core +kmod-ipt-core
+ DEPENDS:=+kmod-sched-core +kmod-ipt-core +kmod-lib-crc32c
KCONFIG:= \
CONFIG_NET_SCH_CODEL \
CONFIG_NET_SCH_DSMARK \
@@ -784,7 +784,11 @@ define KernelPackage/sched
CONFIG_NET_SCH_FQ \
CONFIG_NET_SCH_PIE \
CONFIG_NET_ACT_POLICE \
+ CONFIG_NET_ACT_GACT \
CONFIG_NET_ACT_IPT \
+ CONFIG_NET_ACT_PEDIT \
+ CONFIG_NET_ACT_SIMP \
+ CONFIG_NET_ACT_CSUM \
CONFIG_NET_EMATCH_CMP \
CONFIG_NET_EMATCH_NBYTE \
CONFIG_NET_EMATCH_META \