aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-11-15 11:26:23 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-11-15 11:26:23 +0000
commitcb126cd576724db0bf8e1abf6dce2ecb764169da (patch)
tree7dd3ac87f34c2e4473d4a0cf444fc3ff7788e643 /package/kernel
parent9bbc37d26b633d967b818b33c31ff2d57e1fed9e (diff)
downloadupstream-cb126cd576724db0bf8e1abf6dce2ecb764169da.tar.gz
upstream-cb126cd576724db0bf8e1abf6dce2ecb764169da.tar.bz2
upstream-cb126cd576724db0bf8e1abf6dce2ecb764169da.zip
Package bcm63xx-pcmcia kernel module and fix compilation
SVN-Revision: 13212
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/other.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index f82dfdef90..eacf970df3 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -140,6 +140,20 @@ endef
$(eval $(call KernelPackage,pcmcia-core))
+define KernelPackage/pcmcia-bcm63xx
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Broadcom BCM63xx PCMCIA support
+ DEPENDS:=kmod-pcmcia-core @TARGET_brcm63xx
+ KCONFIG:=CONFIG_PCMCIA_BCM63XX
+ FILES:=$(LINUX_DIR)/drivers/pcmcia/bcm63xx_pcmcia.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,41,bcm63xx_pcmcia)
+endef
+
+define KernelPackage/pcmcia-bcm63xx/description
+ Kernel support for PCMCIA/CardBus controller on the BCM63xx SoC
+endef
+
+$(eval $(call KernelPackage,pcmcia-bcm63xx))
define KernelPackage/pcmcia-serial
SUBMENU:=$(OTHER_MENU)