aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorSteffen Weinreich <steve@weinreich.org>2017-04-25 16:44:39 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2017-05-15 22:55:54 +0200
commit9423cf3e9846690c085d34338638b974cf714c30 (patch)
treebd052baa2d9e8fa2e7bf2d226b7449a99e2b7e46 /package/kernel
parent38367c5699f1fc87ec220f318cfaa353b7c46da0 (diff)
downloadupstream-9423cf3e9846690c085d34338638b974cf714c30.tar.gz
upstream-9423cf3e9846690c085d34338638b974cf714c30.tar.bz2
upstream-9423cf3e9846690c085d34338638b974cf714c30.zip
om-watchdog: add support for Teltonika RUT5xx (ramips)
Add rut5xx GPIO PIN selection to om-package startup script. Testet on a RUT500 device, the timeout value of the hardware watchdog is about 280 sec. Signed-off-by: Steffen Weinreich <steve@weinreich.org> [split into two commits, bump PKG_RELEASE] Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/om-watchdog/Makefile2
-rw-r--r--package/kernel/om-watchdog/files/om-watchdog.init9
2 files changed, 10 insertions, 1 deletions
diff --git a/package/kernel/om-watchdog/Makefile b/package/kernel/om-watchdog/Makefile
index cf92ffb641..403069b816 100644
--- a/package/kernel/om-watchdog/Makefile
+++ b/package/kernel/om-watchdog/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=om-watchdog
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_VERSION:=1
include $(INCLUDE_DIR)/package.mk
diff --git a/package/kernel/om-watchdog/files/om-watchdog.init b/package/kernel/om-watchdog/files/om-watchdog.init
index 7d5d216509..906ee665fd 100644
--- a/package/kernel/om-watchdog/files/om-watchdog.init
+++ b/package/kernel/om-watchdog/files/om-watchdog.init
@@ -48,6 +48,15 @@ get_gpio() {
return 17
;;
esac
+ elif [ -r /lib/ramips.sh ]; then
+ . /lib/ramips.sh
+ local board=$(ramips_board_name)
+
+ case "$board" in
+ "rut5xx")
+ return 11
+ ;;
+ esac
else
#we assume it is om1p in this case
return 3