aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2015-08-09 17:19:00 +0000
committerHauke Mehrtens <hauke@openwrt.org>2015-08-09 17:19:00 +0000
commitef574b45853e95ece29a0bbd470f54dbc282dc07 (patch)
tree598e5e26209d9e6aa8e6d811a88a27d61def1515 /package/kernel
parent29d2e246e006bd58eaee5ab53704faf230dc75c5 (diff)
downloadupstream-ef574b45853e95ece29a0bbd470f54dbc282dc07.tar.gz
upstream-ef574b45853e95ece29a0bbd470f54dbc282dc07.tar.bz2
upstream-ef574b45853e95ece29a0bbd470f54dbc282dc07.zip
CC: kernel: crypto: fix module loading of aead.ko
The name of the module was wrong before. This should fix #20283. backport of r46574. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@46577 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/crypto.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 22c790d2ee..c8e0fbb043 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -41,7 +41,7 @@ define KernelPackage/crypto-aead
CONFIG_CRYPTO_AEAD \
CONFIG_CRYPTO_AEAD2
FILES:=$(LINUX_DIR)/crypto/aead.ko
- AUTOLOAD:=$(call AutoLoad,09,crypto_aead,1)
+ AUTOLOAD:=$(call AutoLoad,09,aead,1)
$(call AddDepends/crypto)
endef