aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-08-23 09:41:27 +0000
committerJonas Gorski <jogo@openwrt.org>2015-08-23 09:41:27 +0000
commitecdc42cc5b84a9234a992270a95ca9d8da3d61e1 (patch)
tree5476a8500bdd84d57c85abc9edafe8e8cd46fe5a /package/kernel
parent47a6648245f6315263845bb4463c4226fa4a0b30 (diff)
downloadupstream-ecdc42cc5b84a9234a992270a95ca9d8da3d61e1.tar.gz
upstream-ecdc42cc5b84a9234a992270a95ca9d8da3d61e1.tar.bz2
upstream-ecdc42cc5b84a9234a992270a95ca9d8da3d61e1.zip
CC: mac80211: disable ipw2x00 for big endian targets
The ipw2x00 drivers assume that the system they are running is little endian, and access everything in native byte order. When run on a big endian system, everything breaks apart. Since fixing this is non trivial on a first glance, disable them for big endian targets. Backport of r46708. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@46710 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/mac80211/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 1f15b40e87..a1eedce014 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -707,7 +707,7 @@ endef
define KernelPackage/net-libipw
$(call KernelPackage/mac80211/Default)
TITLE:=libipw for ipw2100 and ipw2200
- DEPENDS:=@PCI_SUPPORT +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-aes +kmod-crypto-michael-mic +kmod-lib80211 +kmod-cfg80211 +@DRIVER_WEXT_SUPPORT
+ DEPENDS:=@PCI_SUPPORT +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-aes +kmod-crypto-michael-mic +kmod-lib80211 +kmod-cfg80211 +@DRIVER_WEXT_SUPPORT @!BIG_ENDIAN
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/ipw2x00/libipw.ko
AUTOLOAD:=$(call AutoProbe,libipw)
endef