aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2010-10-28 08:50:43 +0000
committerHamish Guthrie <hcg@openwrt.org>2010-10-28 08:50:43 +0000
commitc1d208821d069359f40127f12b3bf35ad41ff649 (patch)
treef50b564f4a0207d018e738d5a9abf39c812cc4af /package/kernel
parent2701bec5644ed1b03779cec609a0986537990ea7 (diff)
downloadupstream-c1d208821d069359f40127f12b3bf35ad41ff649.tar.gz
upstream-c1d208821d069359f40127f12b3bf35ad41ff649.tar.bz2
upstream-c1d208821d069359f40127f12b3bf35ad41ff649.zip
[packages] kernel: Add kernel module for OMAP WDT
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23689 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/other.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 53080f8cdf..b5b659a967 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -680,6 +680,22 @@ endef
$(eval $(call KernelPackage,wdt-geode))
+define KernelPackage/wdt-omap
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=OMAP Watchdog timer
+ DEPENDS:=@(TARGET_omap24xx||TARGET_omap35xx)
+ KCONFIG:=CONFIG_OMAP_WATCHDOG
+ FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/omap_wdt.ko
+ AUTOLOAD:=$(call AutoLoad,50,omap_wdt.ko)
+endef
+
+define KernelPackage/wdt-omap/description
+ Kernel module for TI omap watchdog timer.
+endef
+
+$(eval $(call KernelPackage,wdt-omap))
+
+
define KernelPackage/wdt-sc520
SUBMENU:=$(OTHER_MENU)
TITLE:=Natsemi SC520 Watchdog support