aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-09-05 23:16:24 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-09-05 23:16:24 +0000
commit5f3d84fcebadf6dbecce2e57c5c36eb1d610f6e9 (patch)
tree0d56757bfec45d0889bbd4b8f38536f3a289318e /package/kernel
parent97e87b0afbf72bcef289ae4405d4fcd92df391b7 (diff)
downloadupstream-5f3d84fcebadf6dbecce2e57c5c36eb1d610f6e9.tar.gz
upstream-5f3d84fcebadf6dbecce2e57c5c36eb1d610f6e9.tar.bz2
upstream-5f3d84fcebadf6dbecce2e57c5c36eb1d610f6e9.zip
[PATCH v5 2/4] kernel: add VirtIO device support
Add support for VirtIO-based paravirtualized devices used by various virtualization platforms. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22943 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/virtual.mk48
1 files changed, 48 insertions, 0 deletions
diff --git a/package/kernel/modules/virtual.mk b/package/kernel/modules/virtual.mk
index f988c163c9..c129820f83 100644
--- a/package/kernel/modules/virtual.mk
+++ b/package/kernel/modules/virtual.mk
@@ -7,6 +7,54 @@
VIRTUAL_MENU:=Virtualization Support
+
+define KernelPackage/virtio-balloon
+ SUBMENU:=$(VIRTUAL_MENU)
+ TITLE:=VirtIO balloon driver
+ DEPENDS:=@TARGET_x86
+ KCONFIG:=CONFIG_VIRTIO_BALLOON
+ FILES:=$(LINUX_DIR)/drivers/virtio/virtio_balloon.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,06,virtio-balloon)
+endef
+
+define KernelPackage/virtio-balloon/description
+ Kernel module for VirtIO memory ballooning support
+endef
+
+$(eval $(call KernelPackage,virtio-balloon))
+
+
+define KernelPackage/virtio-net
+ SUBMENU:=$(VIRTUAL_MENU)
+ TITLE:=VirtIO network driver
+ DEPENDS:=@TARGET_x86
+ KCONFIG:=CONFIG_VIRTIO_NET
+ FILES:=$(LINUX_DIR)/drivers/net/virtio_net.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,50,virtio_net)
+endef
+
+define KernelPackage/virtio-net/description
+ Kernel module for the VirtIO paravirtualized network device
+endef
+
+$(eval $(call KernelPackage,virtio-net))
+
+
+define KernelPackage/virtio-random
+ SUBMENU:=$(VIRTUAL_MENU)
+ TITLE:=VirtIO Random Number Generator support
+ DEPENDS:=@TARGET_x86
+ KCONFIG:=CONFIG_HW_RANDOM_VIRTIO
+ FILES:=$(LINUX_DIR)/drivers/char/hw_random/virtio-rng.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,09,virtio-rng)
+endef
+
+define KernelPackage/virtio-random/description
+ Kernel module for the VirtIO Random Number Generator
+endef
+
+$(eval $(call KernelPackage,virtio-random))
+
define KernelPackage/xen-fs
SUBMENU:=$(VIRTUAL_MENU)
TITLE:=Xen filesystem