aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-06-14 10:23:41 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-06-14 10:23:41 +0000
commitf9f525786cd14a6a9787a9418e5a0d085a5a094a (patch)
tree63e383657dfec886c881f2d85bc2c2a7ff881f06 /package/kernel
parent606799f3771d93084ede0be5b9004443716ac1f9 (diff)
downloadupstream-f9f525786cd14a6a9787a9418e5a0d085a5a094a.tar.gz
upstream-f9f525786cd14a6a9787a9418e5a0d085a5a094a.tar.bz2
upstream-f9f525786cd14a6a9787a9418e5a0d085a5a094a.zip
Add support for Option HSDPA modems (#1890)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7630 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/usb.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/kernel/modules/usb.mk b/package/kernel/modules/usb.mk
index 76125a9f5d..99ff481bc2 100644
--- a/package/kernel/modules/usb.mk
+++ b/package/kernel/modules/usb.mk
@@ -245,6 +245,17 @@ define KernelPackage/usb-serial-visor
endef
$(eval $(call KernelPackage,usb-serial-visor))
+define KernelPackage/usb-serial-option
+ $(call usbdep,kmod-usb-serial)
+ TITLE:=Support for Option HSDPA modems
+ DESCRIPTION:=Kernel support for Option HSDPA modems
+ DEPENDS:=@LINUX_2_6
+ KCONFIG:=$(CONFIG_USB_SERIAL_OPTION)
+ FILES:=$(LINUX_DIR)/drivers/usb/serial/option.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,65,option)
+endef
+$(eval $(call KernelPackage,usb-serial-option))
+
define KernelPackage/usb-storage
$(call usbdep,+kmod-scsi-core)