aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-02-16 04:30:48 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-02-16 04:30:48 +0000
commitf728dd2c92f2083b27b090a088ad173803cb6b3a (patch)
treef6103a3cdce743e756cdb9a75e9390015b2b91d2 /package/kernel
parentecdb79831533da95799492f69dbe531bee54f65a (diff)
downloadupstream-f728dd2c92f2083b27b090a088ad173803cb6b3a.tar.gz
upstream-f728dd2c92f2083b27b090a088ad173803cb6b3a.tar.bz2
upstream-f728dd2c92f2083b27b090a088ad173803cb6b3a.zip
[package] add kmod for 2.6.26+ in-kernel uvc video driver (#4637, thanks moh_de)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14526 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/video.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/modules/video.mk b/package/kernel/modules/video.mk
index af0a570615..086bbde91f 100644
--- a/package/kernel/modules/video.mk
+++ b/package/kernel/modules/video.mk
@@ -131,3 +131,20 @@ endef
$(eval $(call KernelPackage,video-pwc))
+define KernelPackage/video-uvc
+ SUBMENU:=$(VIDEO_MENU)
+ TITLE:=USB Video Class (UVC) support
+ DEPENDS:=@LINUX_2_6 @!LINUX_2_6_25 @!LINUX_2_6_24 @!LINUX_2_6_23 @USB_SUPPORT +kmod-usb-core +kmod-video-core
+ KCONFIG:= \
+ CONFIG_USB_VIDEO_CLASS \
+ CONFIG_USB_VIDEO_CLASS_INPUT_EVDEV=y
+ FILES:=$(LINUX_DIR)/drivers/media/video/uvc/uvcvideo.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,90,uvcvideo)
+endef
+
+
+define KernelPackage/video-uvc/description
+ Kernel modules for supporting USB Video Class (UVC) devices.
+endef
+
+$(eval $(call KernelPackage,video-uvc))