aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-07-18 17:26:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-07-18 17:26:17 +0000
commitd888e14478b0ddd5a4ee47248f6ca0d7a15bbed6 (patch)
tree195ef04e1dae1ffd24a5cc4d8d0617705b45e82e /package/kernel
parentf289dc62bd9f68f5a25f1b2a7a98366eccd780a6 (diff)
downloadupstream-d888e14478b0ddd5a4ee47248f6ca0d7a15bbed6.tar.gz
upstream-d888e14478b0ddd5a4ee47248f6ca0d7a15bbed6.tar.bz2
upstream-d888e14478b0ddd5a4ee47248f6ca0d7a15bbed6.zip
kernel: rfkill depends on input-core
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37409 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/001-depends.mk2
-rw-r--r--package/kernel/linux/modules/other.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/001-depends.mk b/package/kernel/linux/modules/001-depends.mk
index e0af735705..445466fb38 100644
--- a/package/kernel/linux/modules/001-depends.mk
+++ b/package/kernel/linux/modules/001-depends.mk
@@ -24,7 +24,7 @@ endef
define SetDepends/rfkill
- DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_gemini||TARGET_cns3xxx||TARGET_ixp4xx)
+ DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_gemini||TARGET_cns3xxx||TARGET_ixp4xx) $(1)
endef
define AddDepends/rfkill
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 03cfbc16f5..960d6fd80f 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -247,7 +247,7 @@ define KernelPackage/rfkill
FILES:= \
$(LINUX_DIR)/net/rfkill/rfkill.ko
AUTOLOAD:=$(call AutoLoad,20,rfkill)
- $(call SetDepends/rfkill)
+ $(call SetDepends/rfkill,+kmod-input-core)
endef
define KernelPackage/rfkill/description