aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2011-07-07 18:21:01 +0000
committerJohn Crispin <blogic@openwrt.org>2011-07-07 18:21:01 +0000
commit8aea078c684898a7dc514e958fa0468581c5c2fa (patch)
treeb620105b25b6c6d75200fa268b011c96d23c35d0 /package/kernel
parent4e1f524715357b21f605c8d9ed0cd26c09c2ae7c (diff)
downloadupstream-8aea078c684898a7dc514e958fa0468581c5c2fa.tar.gz
upstream-8aea078c684898a7dc514e958fa0468581c5c2fa.tar.bz2
upstream-8aea078c684898a7dc514e958fa0468581c5c2fa.zip
kmod-dm9000 should build as a module
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27543 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/netdevices.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/kernel/modules/netdevices.mk b/package/kernel/modules/netdevices.mk
index 9a46689843..2cbc3c1518 100644
--- a/package/kernel/modules/netdevices.mk
+++ b/package/kernel/modules/netdevices.mk
@@ -626,10 +626,12 @@ $(eval $(call KernelPackage,ifb))
define KernelPackage/dm9000
SUBMENU:=$(NETWORK_DEVICES_MENU)
- TITLE:=Davicom 9000 Ethernet support (in-kernel)
- KCONFIG:=CONFIG_DM9000=y \
+ TITLE:=Davicom 9000 Ethernet support
+ KCONFIG:=CONFIG_DM9000 \
CONFIG_DM9000_DEBUGLEVEL=4 \
CONFIG_DM9000_FORCE_SIMPLE_PHY_POLL=y
+ FILES:=$(LINUX_DIR)/drivers/net/dm9000.ko
+ AUTOLOAD:=$(call AutoLoad,34,dm9000)
endef
define KernelPackage/dm9000/description