aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-10-17 22:46:16 +0000
committerJohn Crispin <blogic@openwrt.org>2012-10-17 22:46:16 +0000
commit4b32d3db2d0abdc93d7f67532781bd62a00a255e (patch)
treeeaa96b71a72c1a14f13f766dcc6314ff75e257c3 /package/kernel
parent16ed01db05cf25221a62baf3c8eba135f933a6b1 (diff)
downloadupstream-4b32d3db2d0abdc93d7f67532781bd62a00a255e.tar.gz
upstream-4b32d3db2d0abdc93d7f67532781bd62a00a255e.tar.bz2
upstream-4b32d3db2d0abdc93d7f67532781bd62a00a255e.zip
ixp4xx/cns3xxx: add rfkill module support
Both ixp4xx and cns3xxx targets support RFKILL in the kernel. Also add a RFKILL_GPIO default for kernel config Signed-off-by: Tim Harvey <tharvey@gateworks.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33831 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/001-depends.mk4
-rw-r--r--package/kernel/modules/other.mk3
2 files changed, 4 insertions, 3 deletions
diff --git a/package/kernel/modules/001-depends.mk b/package/kernel/modules/001-depends.mk
index 6c493018df..e0af735705 100644
--- a/package/kernel/modules/001-depends.mk
+++ b/package/kernel/modules/001-depends.mk
@@ -24,11 +24,11 @@ endef
define SetDepends/rfkill
- DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_gemini)
+ DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_gemini||TARGET_cns3xxx||TARGET_ixp4xx)
endef
define AddDepends/rfkill
- DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86):kmod-rfkill $(1)
+ DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_cns3xxx||TARGET_ixp4xx):kmod-rfkill $(1)
endef
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 57614387a7..f370f65129 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -363,7 +363,8 @@ define KernelPackage/rfkill
KCONFIG:= \
CONFIG_RFKILL \
CONFIG_RFKILL_INPUT=y \
- CONFIG_RFKILL_LEDS=y
+ CONFIG_RFKILL_LEDS=y \
+ CONFIG_RFKILL_GPIO=y
FILES:= \
$(LINUX_DIR)/net/rfkill/rfkill.ko
AUTOLOAD:=$(call AutoLoad,20,rfkill)