aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-12-10 21:05:32 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-12-10 21:05:32 +0000
commit1d24cf3f90cbd6bc0179874326554a7d7bf119c5 (patch)
tree337483e00e81eb5f8877e210c3a3db0475ef1263 /package/kernel
parent5364c8124e5ab6622f7fc05c123bcd4b97d77415 (diff)
downloadupstream-1d24cf3f90cbd6bc0179874326554a7d7bf119c5.tar.gz
upstream-1d24cf3f90cbd6bc0179874326554a7d7bf119c5.tar.bz2
upstream-1d24cf3f90cbd6bc0179874326554a7d7bf119c5.zip
package/kernel: enable CONFIG_SND_SOC_DMAENGINE_PCM in sound-soc-core
This is required for 3.6+ kernels and some sound SoC modules. Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34618 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/sound.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/modules/sound.mk b/package/kernel/modules/sound.mk
index 6f83701dfc..f80fa36c01 100644
--- a/package/kernel/modules/sound.mk
+++ b/package/kernel/modules/sound.mk
@@ -149,6 +149,7 @@ define KernelPackage/sound-soc-core
DEPENDS:=+kmod-regmap
KCONFIG:= \
CONFIG_SND_SOC \
+ CONFIG_SND_SOC_DMAENGINE_PCM=y \
CONFIG_SND_SOC_ALL_CODECS=n
FILES:=$(LINUX_DIR)/sound/soc/snd-soc-core.ko
AUTOLOAD:=$(call AutoLoad,55, snd-soc-core)