aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-03-18 19:02:28 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-03-18 19:02:28 +0000
commitf1895391035ee5ea09878233733f25873162c3ac (patch)
tree8659f16fab6a6361eae669e199a34575a240cb11 /package/kernel
parent0cc006ea1c8a48cd3cc76cd02d9cb164cdb8f398 (diff)
downloadupstream-f1895391035ee5ea09878233733f25873162c3ac.tar.gz
upstream-f1895391035ee5ea09878233733f25873162c3ac.tar.bz2
upstream-f1895391035ee5ea09878233733f25873162c3ac.zip
[package] kernel: add kmod-usb-net-ipheth (#10157)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30981 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/usb.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/modules/usb.mk b/package/kernel/modules/usb.mk
index e4f099510c..fedff20850 100644
--- a/package/kernel/modules/usb.mk
+++ b/package/kernel/modules/usb.mk
@@ -913,6 +913,21 @@ endef
$(eval $(call KernelPackage,usb-net-sierrawireless))
+define KernelPackage/usb-net-ipheth
+ TITLE:=Apple iPhone USB Ethernet driver
+ KCONFIG:=CONFIG_USB_IPHETH
+ FILES:=$(LINUX_DIR)/drivers/net/usb/ipheth.ko
+ AUTOLOAD:=$(call AutoLoad,64,ipheth)
+ $(call AddDepends/usb-net)
+endef
+
+define KernelPackage/usb-net-ipheth/description
+ Kernel support for Apple iPhone USB Ethernet driver
+endef
+
+$(eval $(call KernelPackage,usb-net-ipheth))
+
+
define KernelPackage/usb-hid
TITLE:=Support for USB Human Input Devices
KCONFIG:=CONFIG_HID_SUPPORT=y CONFIG_USB_HID CONFIG_USB_HIDDEV=y