aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2011-04-10 10:28:30 +0000
committerHauke Mehrtens <hauke@openwrt.org>2011-04-10 10:28:30 +0000
commite90182d1e48ce40a167820baf8dd7a985d42a19a (patch)
tree708583bf346f74aa84e1fcd3029c916e77bde475 /package/kernel
parent0527ff069415ba67fa7871a68937055ffa87996d (diff)
downloadupstream-e90182d1e48ce40a167820baf8dd7a985d42a19a.tar.gz
upstream-e90182d1e48ce40a167820baf8dd7a985d42a19a.tar.bz2
upstream-e90182d1e48ce40a167820baf8dd7a985d42a19a.zip
kernel: do not build gpiolib into the kernel
fix for r26570. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26574 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/other.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index d05c1c6f08..6c35690d04 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -183,7 +183,7 @@ define KernelPackage/gpio-cs5535
SUBMENU:=$(OTHER_MENU)
TITLE:=AMD CS5535/CS5536 GPIO driver
DEPENDS:=@TARGET_x86 @LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37
- KCONFIG:=CONFIG_CS5535_GPIO CONFIG_GPIOLIB=y
+ KCONFIG:=CONFIG_CS5535_GPIO
FILES:=$(LINUX_DIR)/drivers/char/cs5535_gpio.ko
AUTOLOAD:=$(call AutoLoad,50,cs5535_gpio)
endef
@@ -199,7 +199,7 @@ define KernelPackage/gpio-cs5535-new
SUBMENU:=$(OTHER_MENU)
TITLE:=AMD CS5535/CS5536 GPIO driver with improved sysfs support
DEPENDS:=@TARGET_x86 @!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32)
- KCONFIG:=CONFIG_GPIO_CS5535 CONFIG_GPIOLIB=y
+ KCONFIG:=CONFIG_GPIO_CS5535
FILES:=$(LINUX_DIR)/drivers/gpio/cs5535-gpio.ko
AUTOLOAD:=$(call AutoLoad,50,cs5535-gpio)
endef