aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-03-18 18:49:38 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-03-18 18:49:38 +0000
commitcf3ecd76e9dc153f785522eab857a0876db4b869 (patch)
tree1cd6252114e90d797a656a97b2a9c24eb9dd4f32 /package/kernel
parentb95e2d04f17ad6edbb2803304971beb390c3e654 (diff)
downloadupstream-cf3ecd76e9dc153f785522eab857a0876db4b869.tar.gz
upstream-cf3ecd76e9dc153f785522eab857a0876db4b869.tar.bz2
upstream-cf3ecd76e9dc153f785522eab857a0876db4b869.zip
[package] kernel: add kmod-usb-serial-qualcomm (#8283)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30979 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/usb.mk16
1 files changed, 15 insertions, 1 deletions
diff --git a/package/kernel/modules/usb.mk b/package/kernel/modules/usb.mk
index d454947d93..e4f099510c 100644
--- a/package/kernel/modules/usb.mk
+++ b/package/kernel/modules/usb.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -606,6 +606,20 @@ endef
$(eval $(call KernelPackage,usb-serial-option))
+define KernelPackage/usb-serial-qualcomm
+ TITLE:=Support for Qualcomm USB serial
+ KCONFIG:=CONFIG_USB_SERIAL_QUALCOMM
+ FILES:=$(LINUX_DIR)/drivers/usb/serial/qcserial.ko
+ AUTOLOAD:=$(call AutoLoad,65,qcserial)
+endef
+
+define KernelPackage/usb-serial-qualcomm/description
+ Kernel support for Qualcomm USB Serial devices (Gobi)
+endef
+
+$(eval $(call KernelPackage,usb-serial-qualcomm))
+
+
define KernelPackage/usb-storage
TITLE:=USB Storage support
DEPENDS:= +kmod-scsi-core