aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-03-11 09:12:44 +0000
committerNicolas Thill <nico@openwrt.org>2010-03-11 09:12:44 +0000
commitca597931a9ca178ac6dd979e8eac3aff0b1e07cc (patch)
tree141a7e018475e1d933bb67abe5c3ef494cca8ed9 /package/kernel
parent2b84aa9043fd0bc319d15186a2c09d16e2a0e488 (diff)
downloadupstream-ca597931a9ca178ac6dd979e8eac3aff0b1e07cc.tar.gz
upstream-ca597931a9ca178ac6dd979e8eac3aff0b1e07cc.tar.bz2
upstream-ca597931a9ca178ac6dd979e8eac3aff0b1e07cc.zip
[package] kernel: add missing CONFIG_SND_SOC_ALL_CODECS to kmod-sound-soc-core KCONFIG
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20133 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/sound.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/kernel/modules/sound.mk b/package/kernel/modules/sound.mk
index 1f2cc4e749..e4a4c73cfb 100644
--- a/package/kernel/modules/sound.mk
+++ b/package/kernel/modules/sound.mk
@@ -133,10 +133,13 @@ endef
$(eval $(call KernelPackage,sound-cs5535audio))
+
define KernelPackage/sound-soc-core
$(call KernelPackage/sound/Depends)
TITLE:=SoC sound support
- KCONFIG:=CONFIG_SND_SOC
+ KCONFIG:= \
+ CONFIG_SND_SOC \
+ CONFIG_SND_SOC_ALL_CODECS=n
FILES:=$(LINUX_DIR)/sound/soc/snd-soc-core.ko
AUTOLOAD:=$(call AutoLoad,35, snd-soc-core)
endef