aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-11-20 23:01:07 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-11-20 23:01:07 +0000
commita02a898e8d7e5b7156f15c3247d7160a06961ab5 (patch)
treee69517a882fd292a18834c3a49b100530afb32f1 /package/kernel
parent6292732c5381e8d866ac1acf20ae3f24839fc403 (diff)
downloadupstream-a02a898e8d7e5b7156f15c3247d7160a06961ab5.tar.gz
upstream-a02a898e8d7e5b7156f15c3247d7160a06961ab5.tar.bz2
upstream-a02a898e8d7e5b7156f15c3247d7160a06961ab5.zip
Package ssb glue code out of the kernel, and make b43 be built for non-brcm47xx targets as well
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13301 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/other.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 513517d26c..593aa7fd33 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -192,6 +192,28 @@ endef
$(eval $(call KernelPackage,pcmcia-serial))
+define KernelPackage/ssb
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Silicon Sonics Backplane glue code
+ DEPENDS:=@PCI_SUPPORT @!TARGET_brcm47xx
+ KCONFIG:=\
+ CONFIG_SSB \
+ CONFIG_SSB_B43_PCI_BRIDGE \
+ CONFIG_SSB_DRIVER_PCICORE_POSSIBLE \
+ CONFIG_SSB_PCIHOST \
+ CONFIG_SSB_PCIHOST_POSSIBLE \
+ CONFIG_SSB_POSSIBLE \
+ CONFIG_SSB_SPROM
+ FILES:=$(LINUX_DIR)/drivers/ssb/ssb.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,29,ssb)
+endef
+
+define KernelPackage/ssb/description
+ Silicon Sonics Backplane glue code.
+endef
+
+$(eval $(call KernelPackage,ssb))
+
define KernelPackage/bluetooth
SUBMENU:=$(OTHER_MENU)