aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-07-01 10:34:45 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-07-01 10:34:45 +0000
commit89b6c406bd683a078cc730a71ec578a2e1574e40 (patch)
treebb0a30f70331df89c4d8e7c81e8d882cb50357b2 /package/kernel
parentfd52ba43a16cf0ec34fc03a2989737db1fabab17 (diff)
downloadupstream-89b6c406bd683a078cc730a71ec578a2e1574e40.tar.gz
upstream-89b6c406bd683a078cc730a71ec578a2e1574e40.tar.bz2
upstream-89b6c406bd683a078cc730a71ec578a2e1574e40.zip
kernel/modules: load pppol2tp after pppox
l2tp_ppp needs to be loaded after pppox, otherwise it ends up like this: l2tp_ppp: Unknown symbol pppox_ioctl (err 0) ... during boot. I also fixed the dependency, it should be pppox rather than pppoe. Signed-off-by: Daniel Golle <dgolle@allnet.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32562 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/netsupport.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/modules/netsupport.mk b/package/kernel/modules/netsupport.mk
index 4f7c053a26..ca70c2568b 100644
--- a/package/kernel/modules/netsupport.mk
+++ b/package/kernel/modules/netsupport.mk
@@ -560,10 +560,10 @@ $(eval $(call KernelPackage,pptp))
define KernelPackage/pppol2tp
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=PPPoL2TP support
- DEPENDS:=kmod-ppp +kmod-pppoe +kmod-l2tp
+ DEPENDS:=kmod-ppp +kmod-pppox +kmod-l2tp
KCONFIG:=CONFIG_PPPOL2TP
FILES:=$(LINUX_DIR)/net/l2tp/l2tp_ppp.ko
- AUTOLOAD:=$(call AutoLoad,40,l2tp_ppp)
+ AUTOLOAD:=$(call AutoLoad,41,l2tp_ppp)
endef
define KernelPackage/pppol2tp/description