aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-03-08 09:00:16 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-03-08 09:00:16 +0000
commit7f7388c9504f4eeb438b3423cdc3b4ae773acf77 (patch)
treed77e25d652d7d4b8c66c4db13a4f5265db485401 /package/kernel
parentc95817f23aaba1452295f07b39222a409304b538 (diff)
downloadupstream-7f7388c9504f4eeb438b3423cdc3b4ae773acf77.tar.gz
upstream-7f7388c9504f4eeb438b3423cdc3b4ae773acf77.tar.bz2
upstream-7f7388c9504f4eeb438b3423cdc3b4ae773acf77.zip
package/kernel: add package for the ath79 watchdog
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30851 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/other.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index de2639802e..23d558c955 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -703,6 +703,23 @@ endef
$(eval $(call KernelPackage,wdt-scx200))
+
+define KernelPackage/wdt-ath79
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Atheros AR7XXX/AR9XXX watchdog timer
+ DEPENDS:=@TARGET_ar71xx
+ KCONFIG:=CONFIG_ATH79_WDT
+ FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/ath79_wdt.ko
+ AUTOLOAD:=$(call AutoLoad,50,ath79_wdt)
+endef
+
+define KernelPackage/wdt-ath79/description
+ Kernel module for AR7XXX/AR9XXX watchdog timer.
+endef
+
+$(eval $(call KernelPackage,wdt-ath79))
+
+
define KernelPackage/pwm
SUBMENU:=$(OTHER_MENU)
TITLE:=PWM generic API