aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorVasilis Tsiligiannis <b_tsiligiannis@silverton.gr>2012-07-23 19:17:05 +0000
committerVasilis Tsiligiannis <b_tsiligiannis@silverton.gr>2012-07-23 19:17:05 +0000
commit6a78a82fe3ff971b0030fa3b6dc0986dc9b374fc (patch)
tree6f4bf91873d5cf1cac52c3348d0fd05c6c32def1 /package/kernel
parente5ddfdef84992918489ae911c3dc0954d1a805b5 (diff)
downloadupstream-6a78a82fe3ff971b0030fa3b6dc0986dc9b374fc.tar.gz
upstream-6a78a82fe3ff971b0030fa3b6dc0986dc9b374fc.tar.bz2
upstream-6a78a82fe3ff971b0030fa3b6dc0986dc9b374fc.zip
Revert "[package] kernel/modules: dont only change loading order on IPSEC*-m, propagate this to documentation too"
Preserve alphabetical order on KCONFIG and description for consistency with other module packages This reverts commit r32775. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32791 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/netsupport.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/kernel/modules/netsupport.mk b/package/kernel/modules/netsupport.mk
index 5d78027efa..b4e2a425a0 100644
--- a/package/kernel/modules/netsupport.mk
+++ b/package/kernel/modules/netsupport.mk
@@ -275,11 +275,11 @@ define KernelPackage/ipsec4
KCONFIG:= \
CONFIG_INET_AH \
CONFIG_INET_ESP \
+ CONFIG_INET_IPCOMP \
CONFIG_INET_XFRM_MODE_BEET \
CONFIG_INET_XFRM_MODE_TRANSPORT \
CONFIG_INET_XFRM_MODE_TUNNEL \
- CONFIG_INET_XFRM_TUNNEL \
- CONFIG_INET_IPCOMP
+ CONFIG_INET_XFRM_TUNNEL
FILES:=$(foreach mod,$(IPSEC4-m),$(LINUX_DIR)/net/$(mod).ko)
AUTOLOAD:=$(call AutoLoad,32,$(notdir $(IPSEC4-m)))
endef
@@ -289,11 +289,11 @@ define KernelPackage/ipsec4/description
Includes:
- ah4
- esp4
+ - ipcomp4
- xfrm4_mode_beet
- xfrm4_mode_transport
- xfrm4_mode_tunnel
- xfrm4_tunnel
- - ipcomp
endef
$(eval $(call KernelPackage,ipsec4))
@@ -315,11 +315,11 @@ define KernelPackage/ipsec6
KCONFIG:= \
CONFIG_INET6_AH \
CONFIG_INET6_ESP \
+ CONFIG_INET6_IPCOMP \
CONFIG_INET6_XFRM_MODE_BEET \
CONFIG_INET6_XFRM_MODE_TRANSPORT \
CONFIG_INET6_XFRM_MODE_TUNNEL \
- CONFIG_INET6_XFRM_TUNNEL \
- CONFIG_INET6_IPCOMP
+ CONFIG_INET6_XFRM_TUNNEL
FILES:=$(foreach mod,$(IPSEC6-m),$(LINUX_DIR)/net/$(mod).ko)
AUTOLOAD:=$(call AutoLoad,32,$(notdir $(IPSEC6-m)))
endef
@@ -329,11 +329,11 @@ define KernelPackage/ipsec6/description
Includes:
- ah6
- esp6
+ - ipcomp6
- xfrm6_mode_beet
- xfrm6_mode_transport
- xfrm6_mode_tunnel
- xfrm6_tunnel
- - ipcomp6
endef
$(eval $(call KernelPackage,ipsec6))