aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-10-25 15:13:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-10-25 15:13:11 +0000
commit62a0fac2ccb3d4ab11e528b7e35b92b5ee593aea (patch)
tree92ffa520cde2236b27bf1a62e141c0665871076a /package/kernel
parente21089f9edd3931a54d29a5c00faea309b7a31d8 (diff)
downloadupstream-62a0fac2ccb3d4ab11e528b7e35b92b5ee593aea.tar.gz
upstream-62a0fac2ccb3d4ab11e528b7e35b92b5ee593aea.tar.bz2
upstream-62a0fac2ccb3d4ab11e528b7e35b92b5ee593aea.zip
kernel: fix the pcspkr module, add proper dependencies, add the actual sound module
Backport of r33921 git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@33926 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/sound.mk36
1 files changed, 21 insertions, 15 deletions
diff --git a/package/kernel/modules/sound.mk b/package/kernel/modules/sound.mk
index 4ccdc8b806..3d12ba650f 100644
--- a/package/kernel/modules/sound.mk
+++ b/package/kernel/modules/sound.mk
@@ -7,21 +7,6 @@
SOUND_MENU:=Sound Support
-define KernelPackage/pcspkr
- SUBMENU:=$(SOUND_MENU)
- TITLE:=PC speaker support
- KCONFIG:=CONFIG_INPUT_PCSPKR
- FILES:=$(LINUX_DIR)/drivers/input/misc/pcspkr.ko
- AUTOLOAD:=$(call AutoLoad,50,pcspkr)
-endef
-
-define KernelPackage/pcspkr/description
- This enables sounds (tones) through the pc speaker
-endef
-
-$(eval $(call KernelPackage,pcspkr))
-
-
# allow targets to override the soundcore stuff
SOUNDCORE_LOAD ?= \
soundcore \
@@ -201,3 +186,24 @@ define KernelPackage/sound-soc-gw_avila
endef
$(eval $(call KernelPackage,sound-soc-gw_avila))
+
+
+define KernelPackage/pcspkr
+ DEPENDS:=@!TARGET_x86
+ TITLE:=PC speaker support
+ KCONFIG:= \
+ CONFIG_INPUT_PCSPKR \
+ CONFIG_SND_PCSP
+ FILES:= \
+ $(LINUX_DIR)/drivers/input/misc/pcspkr.ko \
+ $(LINUX_DIR)/sound/drivers/pcsp/snd-pcsp.ko
+ AUTOLOAD:=$(call AutoLoad,50,pcspkr snd-pcsp)
+ $(call AddDepends/input)
+ $(call AddDepends/sound)
+endef
+
+define KernelPackage/pcspkr/description
+ This enables sounds (tones) through the pc speaker
+endef
+
+$(eval $(call KernelPackage,pcspkr))