aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-07-25 15:49:46 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-07-25 15:49:46 +0000
commit536d3097815762e22cf2009f6db68ef233c75fce (patch)
treebdaf229f4d5c6e8b37244b390031ad39ff8f2b90 /package/kernel
parent4dd53d49104787d7b52f1a799500497c5846e35e (diff)
downloadupstream-536d3097815762e22cf2009f6db68ef233c75fce.tar.gz
upstream-536d3097815762e22cf2009f6db68ef233c75fce.tar.bz2
upstream-536d3097815762e22cf2009f6db68ef233c75fce.zip
[package] fix libsas and mvsas dependencies against PCI and not x86
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32847 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/block.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/kernel/modules/block.mk b/package/kernel/modules/block.mk
index cdf3effc5a..819b748b53 100644
--- a/package/kernel/modules/block.mk
+++ b/package/kernel/modules/block.mk
@@ -492,7 +492,6 @@ $(eval $(call KernelPackage,ide-it821x))
define KernelPackage/libsas
SUBMENU:=$(BLOCK_MENU)
TITLE:=SAS Domain Transport Attributes
- DEPENDS:=@TARGET_x86
KCONFIG:=CONFIG_SCSI_SAS_LIBSAS \
CONFIG_SCSI_SAS_ATTRS \
CONFIG_SCSI_SAS_ATA=y \
@@ -531,7 +530,7 @@ $(eval $(call KernelPackage,loop))
define KernelPackage/mvsas
SUBMENU:=$(BLOCK_MENU)
TITLE:=Marvell 88SE6440 SAS/SATA driver
- DEPENDS:=@TARGET_x86 +kmod-libsas
+ DEPENDS:=@PCI_SUPPORT +kmod-libsas
KCONFIG:= \
CONFIG_SCSI_MVSAS \
CONFIG_SCSI_MVSAS_TASKLET=n